Microsoft Internet Explorer URL encoded forward-slash "Same Origin Policy" bypass

ie-sameoriginpolicy-bypass (10039) The risk level is classified as MediumMedium Risk

Description:

Microsoft Internet Explorer could allow a remote attacker to bypass the "Same Origin Policy" restriction and perform malicious actions on a victim's computer. A remote attacker could create a specially-crafted URL request containing a hexadecimal URL encoded "forward-slash" character (%2f) appended prior to an HTTP username, which could allow the attacker to bypass security zone restrictions when a victim clicks the link. This vulnerability could be used to read local files, hijack Web content, or steal a user's cookies.

Note: This vulnerability also affects the Konqueror Web browser, which is included with the K Desktop Environment (KDE) versions 2.2.2 and 3.0 through 3.0.3. See References.


Consequences:

Gain Access

Remedy:

Apply the appropriate patch for your system, as listed in the latest Microsoft Security Bulletin. See References.

— OR —

Use Microsoft Automatic Update if it is supported by your operating system. The original bulletin issued by Microsoft has been superseded.

k Desktop Environment (KDE) versions 2.2.2 and 3.0.3:
Apply the patch for this vulnerability, as listed in KDE Security Advisory 2002-09-08. See References.

For Conectiva Linux:
Upgrade to the latest kdelibs package as listed below. Refer to Conectiva Linux Security Announcement CLSA-2002:525 for more information. See References.

Conectiva Linux 8: 3.0.3-1U80_2cl or later

For Mandrake Linux:
Upgrade to the latest kdelibs package as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2002:064 : kdelibs for more information. See References.

Mandrake Linux 8.1: 2.2.1-6.1mdk or later
Mandrake Linux 8.2: .2.2-49.1mdk or later

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 8.0
  • Debian Debian Linux 3.0
  • KDE K Desktop Environment (KDE) 2.2.2
  • KDE K Desktop Environment (KDE) 3.0 - 3.0.3
  • KDE Konqueror 3.0.3
  • KDE Konqueror
  • MandrakeSoft Mandrake Linux 8.1
  • MandrakeSoft Mandrake Linux 8.2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 6.0
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Linux 7.2
  • RedHat Linux 7.3
  • RedHat Linux 8.0

Reported:

Sep 03, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page