Heimdal Kerberos 5 implementation kf/kfd buffer overflow

heimdal-kf-kfd-bo (10116) The risk level is classified as HighHigh Risk

Description:

Heimdal is vulnerable to several buffer overflows in the kf and kfd daemons, which are used to forward Kerberos authentication credentials. By passing malformed user and file information to a vulnerable client, a remote attacker could overflow a buffer and execute arbitrary code on the system with root privileges.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of Heimdal (0.5 or later), available from the Heimdal Web page. See References.

For SuSE Linux:
Upgrade to the latest heimdal package, as listed below. Refer to SuSE Security Announcement SuSE-SA:2002:034 for more information. See References.

SuSE Linux: 8.0 (Intel): 0.4e-191 or later
SuSE Linux: 7.3 (Intel): 0.4d-132 or later
SuSE Linux: 7.2 (Intel): 0.3e-83 or later
SuSE Linux: 7.3 (Sparc): 0.4d-67 or later
SuSE Linux: 7.3 (PPC): 0.4d-113 or later

For NetBSD:
Refer to NetBSD Security Advisory 2002-018 for upgrade or workaround information. See References.

For Gentoo Linux:
Upgrade to the latest app-crypt/heimdal package, as listed in Gentoo Linux Security Announcement 2002-10-14 15:30 UTC. See References.

For Debian GNU/Linux:
Upgrade to the latest heimdal package, as listed below. Refer to DSA 178-1 for more information. See References.

Debian GNU/Linux 2.2: 0.2l-7.4 or later
Denian GNU/Linux 3.0: 0.4e-7.woody.4 or later

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Debian Debian Linux 2.2
  • Debian Debian Linux 3.0
  • Heimdal Developers Heimdal prior to 0.5
  • NetBSD NetBSD 1.5.1
  • NetBSD NetBSD 1.5.2
  • NetBSD NetBSD 1.5.3
  • NetBSD NetBSD 1.6
  • NetBSD NetBSD CURRENT
  • Novell SuSE Linux Enterprise Server 7.0
  • SuSE SuSE eMail Server III
  • SUSE SuSE Linux 7.2
  • SUSE SuSE Linux 7.3
  • SUSE SuSE Linux 8.0
  • SuSE SuSE Linux Connectivity Server
  • SuSE SuSE Linux Office Server

Reported:

Sep 17, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page