phpWebSite modsecurity.php could be used to include remote PHP files

phpwebsite-modsecurity-file-include (10164) The risk level is classified as MediumMedium Risk


phpWebSite could allow a remote attacker to include malicious PHP files. A remote attacker could send a specially-crafted URL request to the modsecurity.php script that specifies a malicious PHP file from a remote system as a parameter, which would allow the attacker to execute code on the vulnerable Web server.


Gain Access


Upgrade to the latest version of phpWebSite (0.8.3 or later), available from the phpWebSite Web site. See References.


Platforms Affected:

  • Appalachian State University modsecurity.php prior to 1.11
  • Appalachian State University phpWebSite Stable - 0.8.2


Sep 22, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page