Sendmail malformed .forward file could bypass SMRSH security restrictions

sendmail-forward-bypass-smrsh (10232) The risk level is classified as MediumMedium Risk

Description:

Sendmail could allow a local attacker to bypass security restrictions, caused by a vulnerability in the Sendmail Consortium?s Restricted Shell (SMRSH). A local attacker with a valid account could insert special characters into the .forward file to bypass security restrictions and execute shell commands on systems that do not typically allow shell access.


Consequences:

Bypass Security

Remedy:

Apply the smrsh-20020924 patch, available from the Sendmail Web site. See References.

For Conectiva Linux:
Upgrade to the latest sendmail package as listed below. Refer to Conectiva Linux Announcement CLSA-2002:532 for more information. See References.

Conectiva Linux 6.0: 8.11.6-1U60_2cl or later
Conectiva Linux 7.0: 8.11.6-1U70_2cl or later
Conectiva Linux 8.0: 8.11.6-1U80_2cl or later

For FreeBSD:
Upgrade to the latest version of FreeBSD (4.7-STABLE or later) or to the RELENG_4_7 dated after 2002-10-08, or RELENG_4_6, RELENG_4_5, RELENG_4_4, or RELENG_4_3 dated after 2002-10-26 security branch, as listed in FreeBSD Security Advisory FreeBSD-SA-02:41.smrsh. See References.

—OR—

Apply the appropriate patch for your system, as listed in FreeBSD Security Advisory FreeBSD-SA-41.smrsh. See References.

For Mandrake Linux:
Upgrade to the latest sendmail package as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2002:083 for more information. See References.

Mandrake Linux 7.0 and 8.0: 8.11.0-4.1mdk or later
Mandrake Linux 8.1: 8.11.6-4.2mdk or later
Mandrake Linux 8.2: 8.12.1-4.1mdk or later
Mandrake Linux 9.0: 8.12.6-3.1mdk or later

For HP-UX 11.00, 11.11, and 11.22:
Apply the appropriate patch for your system, as listed in Hewlett-Packard Company Security Bulletin HPSBUX0212-234. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 6.0
  • Conectiva Linux 7.0
  • Conectiva Linux 8.0
  • FreeBSD FreeBSD 4.0
  • FreeBSD FreeBSD 4.1
  • FreeBSD FreeBSD 4.1.1
  • FreeBSD FreeBSD 4.2
  • FreeBSD FreeBSD 4.3
  • FreeBSD FreeBSD 4.4
  • FreeBSD FreeBSD 4.5
  • FreeBSD FreeBSD 4.6
  • FreeBSD FreeBSD 4.6.1
  • FreeBSD FreeBSD 4.6.2
  • HP HP-UX 11.00
  • HP HP-UX 11.11
  • HP HP-UX 11.22
  • MandrakeSoft Mandrake Linux 7.2
  • MandrakeSoft Mandrake Linux 8.0 PPC
  • MandrakeSoft Mandrake Linux 8.0
  • MandrakeSoft Mandrake Linux 8.1
  • MandrakeSoft Mandrake Linux 8.1 IA64
  • MandrakeSoft Mandrake Linux 8.2
  • MandrakeSoft Mandrake Linux 8.2 PPC
  • MandrakeSoft Mandrake Linux 9.0
  • NetBSD NetBSD 1.5
  • NetBSD NetBSD 1.5.1
  • NetBSD NetBSD 1.5.2
  • NetBSD NetBSD 1.5.3
  • NetBSD NetBSD 1.6
  • NetBSD NetBSD CURRENT
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Linux 6.2
  • RedHat Linux 7
  • RedHat Linux 7.1
  • RedHat Linux 7.1 for iSeries
  • RedHat Linux 7.1 for pSeries
  • RedHat Linux 7.2
  • RedHat Linux 7.3
  • RedHat Linux 8.0
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • Sendmail Sendmail 8.11
  • Sendmail Sendmail 8.11.6-15
  • Sendmail Sendmail 8.12.0
  • Sendmail Sendmail 8.12.1
  • Sendmail Sendmail 8.12.2
  • Sendmail Sendmail 8.12.3
  • Sendmail Sendmail 8.12.4
  • Sendmail Sendmail 8.12.5
  • Sendmail Sendmail 8.12.6
  • Sendmail Sendmail 8.8.8
  • Sendmail Sendmail 8.9.3

Reported:

Oct 01, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page