FreeBSD/NetBSD Rogue saved game buffer overflow

bsd-rogue-bo (10261) The risk level is classified as HighHigh Risk

Description:

Rogue is vulnerable to a buffer overflow. By creating a malicious saved Rogue game file and calling this file with an overly long parameter, a local attacker could overflow a buffer and execute code on the system with setgid game privileges.


Consequences:

Gain Privileges

Remedy:

For NetBSD-current:
Upgrade to the latest version of NetBSD-current (dated 2002-10-02 or later), as listed in NetBSD Security Advisory 2002-021. See References.

For NetBSD 1.6:
Upgrade to the latest version of NetBSD 1.6 (dated 2002-10-03 or later), as listed in NetBSD Security Advisory 2002-021. See References.

For NetBSD 1.5, 1.5.1, 1.5.2, and 1.5.3:
Upgrade to the latest version of the NetBSD 1.5 branch (dated 2002-10-03 or later), as listed in NetBSD Security Advisory 2002-021. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • FreeBSD FreeBSD 4.6
  • Michael Toy and Glenn Wichman Rogue 5.3
  • NetBSD NetBSD 1.5
  • NetBSD NetBSD 1.5.1
  • NetBSD NetBSD 1.5.2
  • NetBSD NetBSD 1.5.3
  • NetBSD NetBSD 1.6

Reported:

Sep 28, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page