syslog-ng macro expansion buffer overflow

syslogng-macro-expansion-bo (10339) The risk level is classified as HighHigh Risk

Description:

syslog-ng is vulnerable to a buffer overflow, caused by improper bounds checking when performing macro expansion. By creating a destination template file name containing a macro with an overly long "left" variable appended with a constant character, a remote attacker could overflow a buffer and execute arbitrary code on the system, once the macro is expanded.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of syslog-ng (1.5.21 (devel) or later) or (1.4.16 (stable) or later), available from the BalaBit IT Ltd. Web site. See References.

—OR&mdash&

Apply the patch for this vulnerability, as listed in the BugTraq Mailing List posting dated Thu Oct 10 2002 - 07:44:00 CDT. See References.

For Debian GNU/Linux:
Upgrade to the latest syslog-ng package, as listed below. Refer to DSA-175-1 for more information. See References.

Debian GNU/Linux 2.2 (potato): 1.4.0rc3-3.2 or later

Debian GNU/Linux 3.0 (woody): 1.5.15-1.1 or later

For EnGarde Secure Linux Community Edition:
Upgrade to the latest version of syslog-ng (1.4.10-1.0.26 or later), as listed in EnGarde Secure Linux Security Advisory ESA-20021029-028. See References.

For SuSE Linux:
Upgrade to the latest syslog-ng package, as listed below. Refer to SuSE Security Announcement SuSE-SA:2002:039 for more information. See References.

SuSE Linux 8.1 (Intel): 1.4.14-321 or later
SuSE Linux 8.0 (Intel): 1.4.14-319 or later
SuSE Linux 7.3 (Intel): 1.4.12-72 or later
SuSE Linux 7.3 (Sparc): 1.4.12-30 or later
SuSE Linux 7.3 (PPC): 1.4.12-57 or later
SuSE Linux 7.2 (Intel): 1.4.11-89 or later
SuSE Linux 7.1 (AIX): 1.4.11-26 or later
SuSE Linux 7.1 (PPC): 1.4.11-30 or later

For Conectiva Linux:
Upgrade to the latest syslog-ng package, as listed below. Refer to Conectiva Linux Security Announcement CLA-2002:547 for more information. See References.

Conectiva Linux 8.0: 1.4.14-3U80_1cl or later

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • BalaBit syslog-ng 1.4.15 (stable)
  • BalaBit syslog-ng 1.5.20 (development)
  • Conectiva Linux 8.0
  • Debian Debian Linux 2.2
  • Debian Debian Linux 3.0
  • EngardeLinux Secure Linux
  • EngardeLinux Secure Professional
  • SuSE SuSE eMail Server 3.1
  • SuSE SuSE eMail Server III
  • SUSE SuSE Linux 7.1
  • SUSE SuSE Linux 7.2
  • SUSE SuSE Linux 7.3
  • SUSE SuSE Linux 8.0
  • SUSE SuSE Linux 8.1
  • SuSE SuSE Linux Firewall

Reported:

Oct 10, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page