Apache Tomcat invoker servlet used in conjunction with the default servlet reveals source code

tomcat-invoker-source-code (10376) The risk level is classified as LowLow Risk

Description:

Apache Tomcat could allow a remote attacker to obtain sensitive information, caused by improper validation of requests when the invoker servlet is used in conjunction with the default servlet. A remote attacker could send a specially-crafted URL request for a known JavaServer Pages (JSP) to bypass protection and obtain the source code of the requested JSP page. An attacker could then use this information to launch further attacks against the affected server.


Consequences:

Obtain Information

Remedy:

For Gentoo Linux:
Upgrade to the appropriate net-www/tomcat package, as listed in Gentoo Linux Security Announcement 2002-09-25 11:30 UTC. See References.

For Apache Tomcat 4.0.x:
Apply the patch for this vulnerability, available from the Jakarta Web site. See References.

For Debian GNU/Linux:
Upgrade to the latest tomcat4 package, as listed below. Refer to DSA-225-1 for more information. See References.

Debian GNU/Linux 3.0 (woody): 4.0.3-3woody2 or later

As a workaround, disable the invoker servlet.

For other distributions:
Apply the appropriate update for your system. See References.

References:

  • Gentoo Linux Security Announcement 2002-10-15 08:15 UTC: tomcat.
  • Jakarta Web site: Index of /builds/jakarta-tomcat-4.0/release/v4.0.5/bin/hotfix.
  • Mail-Archive.com Web site: [SECURITY] Apache Tomcat 4.x JSP source disclosure vulnerability;Apache Tomcat 4.0.6 released.
  • Sun Alert ID: 239312: Security Vulnerabilities in Tomcat 4.0 Shipped with Solaris 9 and 10.
  • BID-6562: Apache Tomcat Invoker Servlet File Disclosure Vulnerability
  • CVE-2002-1394: Apache Tomcat 4.0.5 and earlier, when using both the invoker servlet and the default servlet, allows remote attackers to read source code for server files or bypass certain protections, a variant of CAN-2002-1148.
  • DSA-225: tomcat4 -- source disclosure
  • OSVDB ID: 9705: Apache Tomcat Invoker/Default Servlet Source Disclosure
  • RHSA-2003-075: tomcat security update for Stronghold
  • SA30899: Sun Solaris 9 Tomcat Multiple Vulnerabilities
  • SA30908: Sun Solaris 10 Tomcat Multiple Vulnerabilities

Platforms Affected:

  • Apache Tomcat 4.0.0
  • Apache Tomcat 4.0.1
  • Apache Tomcat 4.0.2
  • Apache Tomcat 4.0.3
  • Apache Tomcat 4.0.4
  • Apache Tomcat 4.0.5
  • Apache Tomcat 4.1.0
  • Apache Tomcat 4.1.10
  • Apache Tomcat 4.1.3 Beta
  • Apache Tomcat 4.1.9 Beta
  • Debian Debian Linux 3.0
  • RedHat Stronghold
  • Sun Solaris 10 SPARC
  • Sun Solaris 10 x86
  • Sun Solaris 9 x86
  • Sun Solaris 9 SPARC

Reported:

Oct 09, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page