ypserv previously existing map request memory leak

ypserv-map-memory-leak (10423) The risk level is classified as MediumMedium Risk

Description:

ypserv could allow a remote attacker to obtain sensitive information, caused by a memory leak. A remote attacker could request a map that no longer exists to cause the server to leak partial information for the previously existing map, such as the domain name and map name.


Consequences:

Obtain Information

Remedy:

Upgrade to the latest version of ypserv (2.5 or later), available from the Linux NIS/NIS+ Projects Web site. See References.

For Debian GNU/Linux:
Upgrade to the latest nis package, as listed below. Refer to DSA-180-1 for more information. See References.

Debian GNU/Linux 2.2 (potato): 3.8-2.1 or later

Debian GNU/Linux 3.0 (woody): 3.9-6.1 or later

For Red Hat Linux:
Upgrade to the latest ypserv package, as listed below. Refer to RHSA-2002:223-07 for more information. See References.

Red Hat Linux 6.2: 1.3.9-3.6x or later
Red Hat 7.0, 7.1, 7.2 and 7.3: 2.5-2.7x or later

For Gentoo Linux:
Upgrade to the latest net-nds/ypserv package. Refer to Gentoo Linux Security Announcement 200210-010 for upgrade instructions. See References.

For Conectiva Linux:
Upgrade to the latest ypserv package, as listed below. Refer to Conectiva Linux Announcement CLSA-2002:539 for more information. See References.

Conectiva Linux 6.0: 1.3.11-4U60_1cl or later
Conectiva Linux 7.0: 1.3.12-4U70_1cl or later
Conectiva Linux 8.0: 1.3.12-4U80_1cl or later

For Mandrake Linux:
Upgrade to the latest ypservl package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2002:078 : ypserv for more information. See References.

Linux-Mandrake 7.2: 1.3.12-3.2mdk or later
Mandrake Linux 8.0 and 8.1: 1.3.12-3.2mdk or later
Mandrake Linux 8.2 and 9.0: 2.5-1.1mdk or later

For Caldera OpenLinux 3.1 and 3.1.1 (Workstation and Server):
Upgrade to the latest ypserv package (2.0-23 or later), as listed in SCO Security Advisory CSSA-2002-054.0. See References.

For HP-UX:
Apply the appropriate patch for your system, as listed in Hewlett-Packard Company Security Bulletin HPSBTL0210-074. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 6.0
  • Conectiva Linux 7.0
  • Conectiva Linux 8.0
  • Debian Debian Linux 2.2
  • Debian Debian Linux 3.0
  • Gentoo Linux
  • Linux-NIS ypserv 1.3.11
  • Linux-NIS ypserv 1.3.12
  • Linux-NIS ypserv 2.2
  • Linux-NIS ypserv 2.5
  • MandrakeSoft Mandrake Linux 7.2
  • MandrakeSoft Mandrake Linux 8.0
  • MandrakeSoft Mandrake Linux 8.0 PPC
  • MandrakeSoft Mandrake Linux 8.1
  • MandrakeSoft Mandrake Linux 8.1 IA64
  • MandrakeSoft Mandrake Linux 8.2
  • MandrakeSoft Mandrake Linux 8.2 PPC
  • MandrakeSoft Mandrake Linux 9.0
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Linux 6.2
  • RedHat Linux 7
  • RedHat Linux 7.1
  • RedHat Linux 7.1 for iSeries
  • RedHat Linux 7.1 for pSeries
  • RedHat Linux 7.2
  • RedHat Linux 7.3
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • SCO Caldera OpenLinux Server 3.1
  • SCO Caldera OpenLinux Server 3.1.1
  • SCO Caldera OpenLinux Workstation 3.1
  • SCO Caldera OpenLinux Workstation 3.1.1

Reported:

Aug 10, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page