perl-MailTools Mail::Mailer module command execution

mail-mailer-command-execution (10548) The risk level is classified as HighHigh Risk

Description:

Mail::Mailer module could allow a remote attacker to execute commands on the system, caused by a vulnerability that can occur when mailx is used as the default email program. A remote attacker could embed commands within an email message body, which would be executed on the system, once the Mail::Mailer module calls mailx to open the message.


Consequences:

Gain Access

Remedy:

For SuSE Linux:
Upgrade to the latest perl-MailTools package, as listed below. Refer to SuSE Security Announcement SuSE-SA:2002:041 for more information. See References.

SuSE 8.1 (Intel): 1.47-29 or later
SuSE 8.0 (Intel): 1.42-120 or later
SuSE 7.2 and 7.3 (Intel): 1.1401-187 or later
SuSE 7.1 (Intel): 1.1401-188 or later
SuSE 7.3 (Sparc): 1.1401-65 or later
SuSE 7.1 (AXP Alpha): 1.1401-69 or later
SuSE 7.3 (PPC Power PC): 1.1401-110 or later
SuSE 7.1 (PPC Power PC): 1.1401-111 or later

For Gentoo Linux:
Upgrade to the latest dev-perl/MailTools package. Refer to Gentoo Linux Security Announcement 200211-001 for more information. See References.

For Mandrake Linux:
Upgrade to the latest perl-MailTools package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2002:076 : perl-MailTools for more information. See References.

Mandrake Linux 7.2, 8.0, 8.1, 8.2 and 9.0: 1.47-1.1mdk or later

For Debian GNU/Linux 3.0 (woody):
Upgrade to the latest libmailtools-perl package (1.44-1woody1 or later), as listed in DSA-386-1. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

  • Gentoo Linux Security Announcement 200211-001: MailTools.
  • Perldoc.com Web site: Mail::Mailer.
  • BID-6104: PERL-MailTools Remote Command Execution Vulnerability
  • CVE-2002-1271: The Mail::Mailer Perl module in the perl-MailTools package 1.47 and earlier uses mailx as the default mailer, which allows remote attackers to execute arbitrary commands by inserting them into the mail body, which is then processed by mailx.
  • DSA-386: libmailtools-perl -- input validation bug
  • MDKSA-2002:076: Updated perl-MailTools packages fix arbitrary code execution vulnerability
  • OSVDB ID: 4792: perl-MailTools Command Execution

Platforms Affected:

  • Debian Debian Linux 3.0
  • Gentoo Linux
  • Graham Barr perl-MailTools
  • MandrakeSoft Mandrake Linux 7.2
  • MandrakeSoft Mandrake Linux 8.0
  • MandrakeSoft Mandrake Linux 8.0 PPC
  • MandrakeSoft Mandrake Linux 8.1
  • MandrakeSoft Mandrake Linux 8.1 IA64
  • MandrakeSoft Mandrake Linux 8.2
  • MandrakeSoft Mandrake Linux 8.2 PPC
  • MandrakeSoft Mandrake Linux 9.0
  • SuSE SuSE eMail Server 3.1
  • SuSE SuSE eMail Server III
  • SUSE SuSE Linux 7.1
  • SUSE SuSE Linux 7.2
  • SUSE SuSE Linux 7.3
  • SUSE SuSE Linux 8.0
  • SUSE SuSE Linux 8.1

Reported:

Nov 06, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page