Pine "From:" message header denial of service

pine-from-header-dos (10555) The risk level is classified as MediumMedium Risk

Description:

Pine (Program for Internet News & Email) is vulnerable to a denial of service attack, caused by a buffer overflow. By sending an email message with a specially-crafted sender address in the "From:" message header, a remote attacker could overflow a buffer and cause Pine to crash and core dump. The message must be manually removed from the message spool in order for Pine to regain normal functionality.

Note: It is unknown whether this vulnerability could be exploited to execute code on the system.


Consequences:

Denial of Service

Remedy:

Apply the appropriate release for this vulnerability, as listed in Sun Alert ID: 55740. See References.

For EnGarde Secure Linux Community Edition:
Upgrade to the latest pine package (4.50-1.0.9 or later), as listed in EnGarde Secure Linux Security Advisory ESA-20021127-032. See References

For Gentoo Linux:
Upgrade versions net-mail/pine-4.44-r5 and earlier, as listed in Gentoo Linux Security Announcement 200212-1. See References.

For EnGarde Secure Linux Community Edition:
Upgrade to the latest pine package (4.50-1.0.9 or later), as listed in EnGarde Secure Linux Security Advisory 20021127-032. See References.

For Mandrake Linux:
Upgrade to the latest pine package (4.50-1.1mdk or later), as listed in MandrakeSoft Security Advisory MDKSA-2002:084 : pine. See References.

For Conectiva Linux:
Upgrade to the latest pine package, as listed below. Refer to Conectiva Linux Announcement CLSA-2002:551 for more information. See References.

Conectiva Linux 7.0: 4.50L-1U70_1cl or later
Conectiva Linux 8.0: 4.50L-1U80_1cl or later

For Red Hat Linux:
Upgrade to the latest pine package, as listed below. Refer to Red Hat Linux Security Advisory RHSA-2002:270-16 for more information. See References.

Red Hat 6.2: pine-4.44-1.62.1 or later
Red Hat Linux 7.0: pine-4.44-1.70.2 or later
Red Hat Linux 7.1: pine-4.44-1.71.1 or later
Red Hat Linux 7.2: pine-4.44-1.72.2 or later
Red Hat Linux 7.3: pine-4.44-7.73.0 or later
Red Hat Linux 8.0: pine-4.44-14.80.0 or later

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 7.0
  • Conectiva Linux 8.0
  • EngardeLinux Secure Linux
  • EngardeLinux Secure Professional
  • Gentoo Linux
  • MandrakeSoft Mandrake Linux 7.2
  • MandrakeSoft Mandrake Linux 8.0
  • MandrakeSoft Mandrake Linux 8.0 PPC
  • MandrakeSoft Mandrake Linux 8.1
  • MandrakeSoft Mandrake Linux 8.1 IA64
  • MandrakeSoft Mandrake Linux 8.2 PPC
  • MandrakeSoft Mandrake Linux 8.2
  • Novell SuSE Linux Enterprise Server 7.0
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Linux 6.2
  • RedHat Linux 7
  • RedHat Linux 7.1
  • RedHat Linux 7.1 for iSeries
  • RedHat Linux 7.1 for pSeries
  • RedHat Linux 7.2
  • RedHat Linux 7.3
  • RedHat Linux 8.0
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • Sun Linux 5.0
  • SuSE SuSE eMail Server 3.1
  • SuSE SuSE eMail Server III
  • SUSE SuSE Linux 7.1
  • SUSE SuSE Linux 7.2
  • SUSE SuSE Linux 7.3
  • SUSE SuSE Linux 8.0
  • SUSE SuSE Linux 8.1
  • SuSE SuSE Linux Connectivity Server
  • SuSE SuSE Linux Database Server
  • SuSE SuSE Linux Office Server
  • University of Washington Pine 4.44

Reported:

Nov 07, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page