Window Maker image file buffer overflow

window-maker-image-bo (10560) The risk level is classified as HighHigh Risk

Description:

Window Maker is vulnerable to a buffer overflow, caused by improper bounds checking of image files. By sending a specially-crafted image to a vulnerable system, a remote attacker can overflow a buffer and execute code on the system.


Consequences:

Gain Access

Remedy:

For Debian GNU/Linux:
Upgrade to the latest wmaker package, as listed below. Refer to DSA-190-1 for more information. See References.

Debian GNU/Linux 3.0 (woody): 0.80.0-4.1 or later

For Conectiva Linux:
Upgrade to the latest WindowMaker package, as listed below. Refer to Conectiva Linux Security Announcement CLSA-2002:548 for more information. See References.

Conectiva Linux 6.0: 0.62.1-13U60_2cl or later
Conectiva Linux 7.0: 0.65.1-2U70_2cl or later
Conectiva Linux 8.0: 0.80.0-3U80_1cl or later

For Mandrake Linux:
Upgrade to the latest WindowMaker package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2002:085 : WindowMaker for more information. See References.

Mandrake Linux 7.2: 0.62.1-18.2mdk or later
Mandrake Linux 8.0: 0.64.0-8.2mdk or later
Mandrake Linux 8.1: 0.65.1-4.1mdk or later
Mandrake Linux 8.2: 0.80.0-5.1mdk or later
Mandrake Linux 9.0: 0.80.1-2.1mdk or later

For Red Hat Linux:
Upgrade to the latest Window Maker package, as listed below. Refer to RHSA-2003:043-14 for more information. See References.

Red Hat 6.2: 0.61.1-2.3 or later
Red Hat 7.0 and 7.1: 0.64.0-2.3 or later
Red Hat 7.2: 0.65.1-4.2 or later
Red Hat 7.3: 0.80.0-9.3 or later
Red Hat 8.0: 0.80.1-5 or later

For Red Hat Advanced Server 2.1AS:
Upgrade to the latest Window Maker package (0.65.1-4.1 or later), as listed in RHSA-2003:009-03. See References.

For SGI IRIX:
Apply the patch for this vulnerability, as listed in SGI Security Advisory 20031002-01-U. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Alfredo Kojima Window Maker
  • Conectiva Linux 6.0
  • Conectiva Linux 7.0
  • Conectiva Linux 8.0
  • Debian Debian Linux 3.0
  • MandrakeSoft Mandrake Linux 7.2
  • MandrakeSoft Mandrake Linux 8.0
  • MandrakeSoft Mandrake Linux 8.0 PPC
  • MandrakeSoft Mandrake Linux 8.1
  • MandrakeSoft Mandrake Linux 8.1 IA64
  • MandrakeSoft Mandrake Linux 8.2 PPC
  • MandrakeSoft Mandrake Linux 8.2
  • MandrakeSoft Mandrake Linux 9.0
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Linux 6.2
  • RedHat Linux 7
  • RedHat Linux 7.1
  • RedHat Linux 7.1 for iSeries
  • RedHat Linux 7.1 for pSeries
  • RedHat Linux 7.2
  • RedHat Linux 7.3
  • RedHat Linux 8.0
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • SGI IRIX 2.2.1
  • SGI IRIX 2.3
  • Sun Linux 5.0

Reported:

Nov 07, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page