KDE kdelib KIO Telnet:// URL handler remote shell command execution

kde-telnet-command-execution (10603) The risk level is classified as HighHigh Risk

Description:

A vulnerability in the Telnet implementation in K Desktop Environment (KDE) could allow a remote attacker to execute arbitrary commands on the system. By creating a malicious Telnet:// URL containing arbitrary shell commands and sending it to a victim within an HTML email or Web page, a remote attacker could execute arbitrary commands on the system with the same privileges of the victim, once the link is clicked.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of KDE (3.0.5 or later), as listed in KDE Security Advisory 2002-11-11. See References.

—OR—

Apply the appropriate patch for this vulnerability, as listed in KDE Security Advisory 2002-11-11. See References.

For Mandrake Linux:
Upgrade to the latest kdelibs package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2001:079 for more information. See References.

Mandrake Linux 9.0: 3.0.3-30.1mdk later

For Debian GNU/Linux:
Upgrade to the latest kdelibs package, as listed below. Refer to DSA 204-1 for more information. See References.

Debian GNU/Linux 3.0 (woody): 2.2.2-13.woody.5 or later

For Caldera OpenLinux 3.1 and 3.1.1 (Workstation and Server): Upgrade to the latest kdelibs2 packages (2.2.1-6.3 or later), as listed in Caldera International, Inc. Security Advisory CSSA-2003-012.0. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

  • KDE Security Advisory 2002-11-11: rlogin.protocol and telnet.protocol URL KIO Vulnerability.
  • KDE Web site: Getting KDE.
  • SCO Security Advisory CSSA-2003-012.0: Linux: KDE rlogin.protocol and telnet.protocol url kio Vulnerability.
  • BID-6182: KDE KIO Subsystem Network Protocol Implementation Arbitrary Command Execution Vulnerability
  • CVE-2002-1282: Unknown vulnerability in the telnet KIO subsystem (telnet.protocol) of KDE 2.x 2.1 and later allows local and remote attackers to execute arbitrary code via a certain URL.
  • DSA-204: kdelibs -- arbitrary program execution
  • OSVDB ID: 12997: KDE KIO Subsystem telnet Arbitrary Remote Command Execution
  • RHSA-2002-220: Updated KDE packages fix security issues
  • SA8298: OpenLinux update to kdelibs

Platforms Affected:

  • Debian Debian Linux 3.0
  • KDE KDE 2.1 - 2.2.2
  • MandrakeSoft Mandrake Linux 9.0
  • RedHat Linux 7.2
  • RedHat Linux 7.3
  • RedHat Linux 8.0

Reported:

Nov 11, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page