GoAhead ASP script source disclosure

goahead-script-source-disclosure (10885) The risk level is classified as MediumMedium Risk

Description:

GoAhead WebServer could allow a remote attacker to obtain sensitive information, caused by improper filtering of special characters in URL requests. A remote attacker could send a specially-crafted URL request for a known Active Server Pages (ASP) script appended with a (/), (\), (%20) or (%00) character to bypass character filtering and obtain the source code for the requested script.


Consequences:

Obtain Information

Remedy:

Upgrade to the latest version of GoAhead WebServer, or at least up to version 2.1.8, available on the GoAhead Software Web site. See References.

References:

Platforms Affected:

  • GoAhead GoAhead WebServer 2.1.2
  • GoAhead GoAhead WebServer prior to 2.17
  • Microsoft Windows CE
  • QNX QNX Neutrino RTOS
  • Wind River VxWorks
  • ZyXEL P-330W

Reported:

Dec 17, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page