CUPS and Xpdf pdftops filter integer overflow

pdftops-integer-overflow (10937) The risk level is classified as HighHigh Risk

Description:

The pdftops filter in CUPS and Xpdf is vulnerable to an integer overflow that can be exploited by a local or remote attacker to gain elevated privileges. An attacker can exploit this vulnerability by creating and printing a malformed PDF file to gain the privileges of the targeted user, and possibly "lp" user privileges.


Consequences:

Gain Access

Remedy:

For CUPS:
Upgrade to the latest version of CUPS (1.1.18 or later), available from the CUPS Web site. See References.

For Xpdf:
Apply the xpdf-2.01-patch1 patch, available from the Xpdf FTP site. See References.

For SuSE Linux:
Upgrade to the latest CUPS package, as listed below. Refer to SuSE Security Announcement SuSE-SA:2003:002 for more information. See References.

SuSE Linux 8.1 (Intel): 1.1.15-69 or later
SuSE Linux 8.0 (Intel): 1.1.12-90 or later
SuSE Linux 7.3 (Intel): 1.1.10-94 or later
SuSE Linux 7.3 (Sparc): 1.1.10-45 or later
SuSE Linux 7.3 (PPC): 1.1.10-81 or later
SuSE Linux 7.2 (Intel): 1.1.6-122 or later
SuSE Linux 7.1 (Intel): 1.1.6-121 or later
SuSE Linux 7.1 (AXP): 1.1.6-40 or later
SuSE Linux 7.1 (PPC): 1.1.6-53 or later

For Gentoo Linux:
Upgrade versions app-text/xpdf-1.01-r1 and earlier, as listed in Gentoo Linux Security Announcement 200301-1. See References.

For Debian GNU/Linux containing the xpdf package:
Upgrade to the latest xpdf package, as listed below. Refer to DSA-222-1 for more information. See References.

Debian GNU/Linux 2.2 (potato): 0.90-8.1 or later
Debian GNU/Linux 3.0 (woody): 1.00-3.1 or later

For Debian GNU/Linux 2.2 (potato) containing the xpdf-I package:
Upgrade to the latest version of spdf-l (0.90-8.1 or later), as listed in DSA-226-1. See References.

For Debian GNU/Linux 3.0 (alias woody) containing the cupsys package:
Upgrade to the latest version of cupsys (1.1.14-4.4 or later), as listed in DSA-232-2. See References.

For Debian GNU/Linux 2.2 (potato) containing the cupsys package:
Upgrade to the latest version of cupsys (1.0.4-12.1 or later), as listed in DSA-232-1. See References.

For Mandrake Linux:
Upgrade to the latest xpdf package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2003:002:xpdf for more information. See References.

Mandrake Linux 7.2: 1.01-4.2mdk or later
Mandrake Linux 8.0, 8.1, 8.2, and 9.0: 1.01-4.1mdk or later

For TurboLinux 8 (Server and Workstation) containing the cups package:
Upgrade to the latest version of cups (1.1.15-6 or later), as listed in TurboLinux Security Announcement TLSA-2003-4. See References.

For TurboLinux 8 (Server and Workstation) containing the xpdf package:
Upgrade to the latest version of cups (1.00-2 or later), as listed in TurboLinux Security Announcement TLSA-2003-3. See References.

For Red Hat Linux:
Upgrade to the latest xpdf package, as listed below. Refer to RHSA-2003:037-09 for more information. See References.

Red Hat 6.2: xpdf-0.92-1.62.0 or later
Red Hat 7.0:xpdf-0.92-2.70.0 or later
Red Hat 7.1: xpdf-0.92-4.71.0 or later
Red Hat 7.2: xpdf-0.92-8 or later
Red Hat 7.3: xpdf-1.00-5 or later
Red Hat 8.0: xpdf-1.01-10 or later

For Conectiva Linux:
Upgrade to the latest cups package, as listed below. Refer to Conectiva Linux Security Announcement CLSA-2003:702 for more information. See References.

Conectiva Linux 7.0: 1.1.14-1U70_4cl or later
Conectiva Linux 8: 1.1.14-2U80_4cl or later
Conectiva Linux 9: 1.1.18-29091U90_1cl or later

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 7.0
  • Conectiva Linux 8.0
  • Conectiva Linux 9.0
  • Debian Debian Linux 2.2
  • Debian Debian Linux 3.0
  • Easy Software Products CUPS prior to 1.1.18
  • Foolabs Xpdf 2.01 and prior
  • Gentoo Linux
  • MandrakeSoft Mandrake Linux 7.2
  • MandrakeSoft Mandrake Linux 8.0
  • MandrakeSoft Mandrake Linux 8.0 PPC
  • MandrakeSoft Mandrake Linux 8.1
  • MandrakeSoft Mandrake Linux 8.1 IA64
  • MandrakeSoft Mandrake Linux 8.2 PPC
  • MandrakeSoft Mandrake Linux 8.2
  • MandrakeSoft Mandrake Linux 9.0
  • Novell UnitedLinux 1.0
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Linux 6.2
  • RedHat Linux 7
  • RedHat Linux 7.1
  • RedHat Linux 7.1 for iSeries
  • RedHat Linux 7.1 for pSeries
  • RedHat Linux 7.2
  • RedHat Linux 7.3
  • RedHat Linux 8.0
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • SuSE Linux Enterprise Server 8
  • SUSE SuSE Linux 7.1
  • SUSE SuSE Linux 7.2
  • SUSE SuSE Linux 7.3
  • SUSE SuSE Linux 8.0
  • SUSE SuSE Linux 8.1
  • Turbolinux Turbolinux 7 Server
  • Turbolinux Turbolinux 7 Workstation
  • Turbolinux Turbolinux 8 Server
  • Turbolinux Turbolinux 8 Workstation
  • Turbolinux Turbolinux Workstation 6.0

Reported:

Dec 23, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page