libmcrypt libtool memory leak

libmcrypt-libtool-memory-leak (10988) The risk level is classified as MediumMedium Risk

Description:

libmcrypt is vulnerable to a memory leak, caused by a vulnerability regarding the way libtool is used to load algorithms by libmcrypt. A remote or local attacker could use this vulnerability to obtain sensitive information by using a program that uses the libmcrypt library to send a request to libmcrypt to cause a memory leak to occur. An attacker could also use this vulnerability to cause a denial of service by causing multiple requests to be sent to libmcrypt that would consume all available memory resources.


Consequences:

Obtain Information

Remedy:

Upgrade to the latest version of libmcrypt (2.5.5 or later), available from the libmcrypt Web page. See References.

For Gentoo Linux:
Upgrade versions dev-libs/libmcrypt-2.5.1-r4 and earlier, as listed in Gentoo Linux Security Announcement 2003-01-4. See References.

For Debian GNU/Linux:
Upgrade to the latest libmcrypt package, as listed below. Refer to DSA-228-1 for more information. See References.

Debian GNU/Linux 3.0 (woody): 2.5.0-1woody1 or later

For Conectiva Linux:
Upgrade to the latest mcrypt package, as listed below. Refer to Conectiva Linux Announcement CLSA-2003:567 for more information. See References.

Conectiva Linux 7.0: 2.4.9-3U70_1cl or later

For SuSE Linux:
Upgrade to the latest libmcrypt package, as listed below. Refer to SuSE Security Announcement SuSE-SA:2003:0010 for more information. See References.

SuSE Linux 8.1 (Intel): 2.5.2-48 or later
SuSE Linux 8.0 (Intel): 2.4.20-114 or later
SuSE Linux 7.3 (Intel): 2.4.15-98 or later
SuSE Linux 7.3 (Sparc): 2.4.15-53 or later
SuSE Linux 7.3 (PPC): 2.4.15-89 or later
SuSE Linux 7.2 (Intel): 2.4.10-59 or later
SuSE Linux 7.2 (Intel): 2.4.7-19 or later
SuSE Linux 7.1 (AXP): 2.4.7-26 or later
SuSE Linux 7.1 (PPC): 2.4.7-23 or later

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 7.0
  • Conectiva Linux 8.0
  • Debian Debian Linux 3.0
  • Gentoo Linux
  • HEL.L.U.G. libmcrypt prior to 2.5.5
  • Novell SuSE Linux Enterprise Server 7.0
  • SuSE Linux Enterprise Server 8
  • SuSE SuSE eMail Server 3.1
  • SuSE SuSE eMail Server III
  • SUSE SuSE Linux 7.1
  • SUSE SuSE Linux 7.2
  • SUSE SuSE Linux 7.3
  • SUSE SuSE Linux 8.0
  • SUSE SuSE Linux 8.1
  • SuSE SuSE Linux Connectivity Server
  • SuSE SuSE Linux Office Server

Reported:

Jan 03, 2003

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page