Mailman email variable cross-site scripting

mailman-email-variable-xss (11152) The risk level is classified as MediumMedium Risk


GNU Mailman is vulnerable to cross-site scripting, caused by improper filtering of the email parameter. A remote attacker could embed malicious script within the email parameter in a URL request, which would be executed in the victim's Web browser within the security context of the hosting site, once the link is clicked. An attacker could use this vulnerability to steal a victim's cookie-based authentication credentials.


Gain Access


Upgrade to the latest version of net-mail/mailman (2.1.1 or later), as listed in Gentoo Linux Security Announcement 2003-02-05. See References.

For Debian GNU/Linux 3.0 (woody):
Upgrade to the latest mailman package (2.1.1-1 or later), as listed in DSA-436-1. See References.

For other distributions:
Contact your vendor for upgrade or patch information.


Platforms Affected:

  • Debian Debian Linux 3.0
  • Gentoo Linux
  • GNU Mailman 2.1


Jan 24, 2003

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page