Noffle multiple buffer overflows

noffle-multiple-bo (11181) The risk level is classified as HighHigh Risk

Description:

Noffle is vulnerable to multiple remote buffer overflow vulnerabilities. A remote attacker could exploit this vulnerabilities to cause the Noffle server to crash or possibly execute arbitrary code on the system with the same privileges of the Noffle server.


Consequences:

Gain Access

Remedy:

For Debian GNU/Linux 3.0 (woody):
Upgrade to the latest noffle package (1.0.1-1.1 or later), as listed in DSA-244-1. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

  • Noffle Web site: Noffle.
  • BID-6695: Noffle Remote Memory Corruption Vulnerability
  • CVE-2003-0037: Buffer overflows in noffle news server 1.0.1 and earlier allow remote attackers to cause a denial of service (segmentation fault) and possibly execute arbitrary code.
  • DSA-244: noffle -- buffer overflows
  • OSVDB ID: 13487: Noffle News Server Multiple Unspecified Overflows
  • SA7955: Debian updates to noffle

Platforms Affected:

  • Debian Debian Linux 3.0
  • Noffle Project Developers Noffle 1.0.1

Reported:

Jan 27, 2003

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page