MySQL mysql_change_user() double-free memory pointer denial of service

mysql-mysqlchangeuser-doublefree-dos (11199) The risk level is classified as MediumMedium Risk

Description:

MySQL is vulnerable to a denial of service attack, caused by a vulnerability regarding a double-free memory pointer in the mysql_change_user() function. A remote or local attacker with a valid user account and using a malicious MySQL client could exploit this vulnerability to cause the mysqld service to crash.


Consequences:

Denial of Service

Remedy:

Upgrade to the latest version of MySQL (3.23.55 or later), available from the MySQL Web site. See References.

For OpenPKG:
Upgrade to the latest mySQL package, as listed below. Refer to OpenPKG Security Advisory OpenPKG-SA-2003.008 for more information. See References.

OpenPKG CURRENT: 3.23.55-20030124 or later
OpenPKG 1.2: 3.23.54a-1.2.1 or later
OpenPKG 1.1: 3.23.52-1.1.2 or later

For Mandrake Linux:
Upgrade to the latest MySQL package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2003:013:MySQL for more information. See References.

Mandrake Linux 7.2 and Single Network Firewall 7.2: 3.23.31-1.4mdk or later
Mandrake Linux 8.0: 3.23.36-2.3mdk or later
Mandrake Linux 8.1: 3.23.41-5.3mdk or later
Mandrake Linux 8.2: 3.23.47-5.3mdk or later
Mandrake Linux 9.0: 3.23.52-1.3mdk or later

For EnGarde Secure Linux Community Edition:
Upgrade to the latest MySQL package (3.23.36-1.0.22 or later), as listed in EnGarde Secure Linux Security Advisory 20030220-004. See References.

For Red Hat Linux:
Upgrade to the latest mysql package, as listed below. Refer to RHSA-2003:093-14 for more information. See References.

Red Hat 7.1: 3.23.56-1.71 or later
Red Hat 7.2: 3.23.56-1.72 or later
Red Hat 7.3: 3.23.56-1.73 or later
Red Hat 8.0: 3.23.56-1.80 or later
Red Hat 9: 3.23.56-1.9 or later

For Red Hat Linux containing the mysql package:
Upgrade to the latest mysql package, as listed below. Refer to RHSA-2003:094-12 for more information. See References.

Red Hat Enterprise Linux AS (v. 2.1), ES (v.2.1), WS (v.2.1), and Red Hat Linux Advanced Workstation 2.1 for the Itanium Processor: 3.23.56-1.72 or later

For Debian GNU/Linux:
Upgrade to the latest mysql package, as listed below. Refer to DSA-303-1 for more information. See References.

Debian GNU/Linux 3.0 (woody): 3.23.49-8.4 or later
Debian GNU/Linux 2.2 (potato): 3.22.32-6.4 or later

For Conectiva Linux:
Upgrade to the latest mysql package, as listed below. Refer to Conectiva Linux Security Announcement CLSA-2003:743 for more information. See References.

Conectiva Linux 7.0: 3.23.58-1U70_4cl or later
Conectiva Linux 8: 3.23.58-1U80_3cl or later
Conectiva Linux 9: 3.23.58-20507U90_1cl or later

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 7.0
  • Conectiva Linux 8.0
  • Conectiva Linux 9.0
  • Debian Debian Linux 2.2
  • Debian Debian Linux 3.0
  • Digital OSF/1
  • EngardeLinux Secure Linux
  • FreeBSD FreeBSD
  • MandrakeSoft Mandrake Linux 7.2
  • MandrakeSoft Mandrake Linux 8.0 PPC
  • MandrakeSoft Mandrake Linux 8.0
  • MandrakeSoft Mandrake Linux 8.1 IA64
  • MandrakeSoft Mandrake Linux 8.1
  • MandrakeSoft Mandrake Linux 8.2
  • MandrakeSoft Mandrake Linux 8.2 PPC
  • MandrakeSoft Mandrake Linux 9.0
  • MandrakeSoft Mandrake Single Network Firewall 7.2
  • MySQL MySQL 3.23.31
  • MySQL MySQL 3.23.36
  • MySQL MySQL 3.23.41
  • MySQL MySQL 3.23.47
  • MySQL MySQL 3.23.52
  • MySQL MySQL 3.23.53
  • MySQL MySQL 3.23.54
  • MySQL MySQL 3.23.54a
  • OpenPKG OpenPKG 1.1
  • OpenPKG OpenPKG 1.2
  • OpenPKG OpenPKG CURRENT
  • RedHat Enterprise Linux 2.1 AW
  • RedHat Enterprise Linux 2.1 WS
  • RedHat Enterprise Linux 2.1 ES
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Linux 7.1
  • RedHat Linux 7.1 for iSeries
  • RedHat Linux 7.1 for pSeries
  • RedHat Linux 7.2
  • RedHat Linux 7.3
  • RedHat Linux 8.0
  • RedHat Linux 9.0
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • SCO Caldera OpenUnix

Reported:

Jan 23, 2003

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page