Courier-IMAP authpgsqllib username SQL injection

courierimap-authmysqllib-sql-injection (11213) The risk level is classified as MediumMedium Risk

Description:

Courier-IMAP is vulnerable to SQL injection in the authlib/authpgsqllib.c PostgreSQL authentication module, caused by improper validation of usernames. If a remote attacker attempts to authenticate with a specially-crafted username, the attacker could modify the logic of underlying SQL queries and add, modify, or delete data from the backend PostgreSQL database.


Consequences:

Data Manipulation

Remedy:

Upgrade to the latest version of Courier-IMAP (1.7.0 or later), available from the Inter7 Internet Technologies Web site. See References.

For Debian Linux:
Upgrade to the latest courier-authpostgresql package, as listed below. Refer to DSA-247-1for more information. See References.

Debian GNU/Linux 3.0 (woody): 0.37.3-3.3 or later

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Courier-MTA Courier-IMAP 1.6.2 and prior
  • Debian Debian Linux 3.0

Reported:

Jan 23, 2003

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page