BladeEnc myFseek() code execution

bladeenc-myfseek-code-execution (11227) The risk level is classified as MediumMedium Risk

Description:

BladeEnc could allow a remote attacker to execute arbitrary code on the system, caused by a vulnerability in the myFseek() function. The myFseek() function fails to properly validate the "offset" variable. A remote attacker could exploit this vulnerability by creating a malicious audio file, and sending it to a victim as an email attachment or hosting it on a Web site, which would cause arbitrary code to be executed on the victim's system when encoded using the BladeEnc encoder.


Consequences:

Gain Access

Remedy:

For Gentoo Linux:
Upgrade to the latest version of bladeenc (0.94.2-r1 and later), as listed in Gentoo Linux Security Announcement 200302-04. See References.

For other distributions: Contact your vendor for upgrade or patch information..

References:

Platforms Affected:

  • Gentoo Linux
  • Tord Jansson BladeEnc 0.94.2 and prior

Reported:

Feb 02, 2003

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page