Apcupsd log_event() format string attack

apcupsd-logevent-format-string (11334) The risk level is classified as HighHigh Risk

Description:

Apcupsd is vulnerable to a format string attack, caused by a vulnerability in the log_event() function. A remote attacker could exploit this vulnerability by passing a specially-crafted packet containing a malicious format string to the program to execute arbitrary code on the system with privileges of the Apcupsd process.


Consequences:

Gain Privileges

Remedy:

Upgrade to the latest version of Apcupsd (3.8.6 or later), available from the Apcupsd Web page. See References.

For Mandrake Linux 8.1, 8.2, and 9.0:
Upgrade to the latest apcupsd package (3.10.5-1.1mdk or later), as listed in MandrakeSoft Security Advisory MDKSA-2003:018:apcupsd. See References.

For Gentoo Linux:
Upgrade to the latest version of apcupsd (3.10.5 or later), as listed in Gentoo Linux Security Announcement 200302-13. See References.

For SuSE Linux:
Upgrade to the latest apcupsd package, as listed below. Refer to SuSE Security Announcement SuSE-SA:2003:022 for more information. See References.

For SuSE Linux: Upgrade to the latest apcupsd package, as listed below. Refer to SuSE Security Announcement SuSE-SA:2003:022 for more information. See References.

SuSE 8.1: 3.8.6-17 or later
SuSE 8.0: 3.8.6-16 or later
SuSE 7.3: 3.8.2-70 or later
SuSE 7.3 (Sparc): 3.8.2-30 or later
SuSE 7.3 (Power PPC): 3.8.2-56 or later

For Debian GNU/Linux 3.0 (woody):
Upgrade to the latest version of apcupsd (3.8.5-1.1.1 or later), as listed in DSA-277-1. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

  • Apcupsd Web site: Apcupsd, a daemon for controlling APC UPSes.
  • Gentoo Linux Security Announcement 200302-13: apcupsd -- remote root vulnerability and buffer overflows.
  • BID-6828: APC apcupsd Client Syslog Format String Vulnerability
  • BID-7200: APC apcupsd Multiple Buffer Overflow Vulnerabilities
  • CVE-2003-0098: Unknown vulnerability in apcupsd before 3.8.6, and 3.10.x before 3.10.5, allows remote attackers to gain root privileges, possibly via format strings in a request to a slave server.
  • DSA-277: apcupsd -- buffer overflows
  • MDKSA-2003:018: Updated apcupsd packages fix buffer overflow and remove vulnerability
  • OSVDB ID: 10748: APC apcupsd Slave Server Request Format String
  • SECTRACK ID: 1006108: Apcupsd Format String Flaw May Let Remote Users Gain Root Access
  • SUSE-SA:2003:022: apcupsd: remote system compromise

Platforms Affected:

  • APC Apcupsd 3.10.4
  • APC Apcupsd 3.8.5
  • Debian Debian Linux 3.0
  • Gentoo Linux
  • MandrakeSoft Mandrake Linux 8.1
  • MandrakeSoft Mandrake Linux 8.1 IA64
  • MandrakeSoft Mandrake Linux 8.2
  • MandrakeSoft Mandrake Linux 8.2 PPC
  • MandrakeSoft Mandrake Linux 9.0
  • SUSE SuSE Linux 7.3
  • SUSE SuSE Linux 8.0
  • SUSE SuSE Linux 8.1

Reported:

Feb 15, 2003

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page