UnZip "dot dot" directory traversal

unzip-dotdot-directory-traversal (12004) The risk level is classified as MediumMedium Risk

Description:

UnZip could allow a remote attacker to overwrite or create files on the system, caused by improper filtering of file names. By creating a zip file in an archive with a file name containing a modified "dot dot" sequence that contains invalid characters between the dots, a remote attacker could traverse directories and create new files or overwrite any known file in any directory on the system, once the victim attempts to unzip the zipped file. An attacker could exploit this vulnerability by hosting the malicious file on a Web site or by sending it to the victim as an email attachment.


Consequences:

File Manipulation

Remedy:

For Red Hat Linux:
Upgrade to the latest unzip package, as listed below. Refer to RHSA-2003:199-14 for more information. See References.

Red Hat 7.1 for iSeries and pSeries, 7.2, and 7.3: 5.50-31 or later
Red Hat 8.0: 5.50-32 or later
Red Hat 9: 5.50-33 or later

For Red Hat Linux containing the unzip package:
Upgrade to the latest unzip package, as listed below. Refer to RHSA-2003:200-07 for more information. See References.

Red Hat Enterprise Linux AS (v. 2.1), ES (v. 2.1), WS (v. 2.1): 5.50-13 or later
Advanced Workstation 2.1 for the Itanium Processor: 5.50-13 or later

For Conectiva Linux:
Upgrade to the latest unzip package, as listed below. Refer to Conectiva Linux Security Announcement CLSA-2003:724 for more information. See References.

Conectiva Linux 7.0: 5.50-1U70_3cl or later
Conectiva Linux 8: 5.50-1-1U80_3cl or later
Conectiva Linux 9: 5.50-1386OU90_2cl or later

For Immunix 7+:
Upgrade to the latest version of unzip (5.50-11_imnx_1 or later), as listed in Immunix Secured OS Security Advisory IMNX-2003-7+-017-01. See References.

For Turbolinux:
Upgrade to the latest unzip package (5.50-4 or later), as listed in Turbolinux Security Advisory TLSA-2003-42. See References.

For Mandrake Linux:
Upgrade to the latest unzip package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2003:073-1 : unzip for more information. See References.

Mandrake Linux 8.2, 9.0, 9.1, Multi Network Firewall 8.2, and Corporate Server 2.1: 5.50-4.2mdk or later

For Gentoo Linux:
Upgrade to the latest version of unzip (5.50-r2 or later), as listed in Gentoo Linux Security Announcement 200307-02. See References.

For OpenPKG:
Upgrade to the latest infozip package, as listed below. Refer to OpenPKG Security Advisory OpenPKG-SA-2003.033-infozip for more information. See References.

OpenPKG CURRENT: 20030710-20030710 or later
OpenPKG 1.2: 1.2.0-1.2.1 or later
OpenPKG 1.1: 1.1.0-1.1.1 or later

For Debian GNU/Linux 3.0 (alias woody):
Upgrade to the latest unzip package (5.50-1woody2 or later), as listed in DSA-344-2. See References.

For Slackware Linux:
Upgrade to the latest infozip package, as listed below. Refer to slackware-security Mailing List, Mon, 25 Aug 2003 20:39:27 -0700 (PDT) for more information. See References.

Slackware Linux 9.0 and -current: 5.50 or later

For Caldera OpenLinux Server and Workstation 3.1.1:
Upgrade to the latest version of unzip (5.40-6MR or later), as listed in SCO Security Advisory CSSA-2003-031.0. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 7.0
  • Conectiva Linux 8.0
  • Conectiva Linux 9.0
  • Debian Debian Linux 3.0
  • FreeBSD FreeBSD
  • Gentoo Linux
  • Immunix Immunix OS 7+-beta
  • Info-ZIP UnZip 5.50
  • MandrakeSoft Mandrake Linux 8.2
  • MandrakeSoft Mandrake Linux 8.2 PPC
  • MandrakeSoft Mandrake Linux 9.0
  • MandrakeSoft Mandrake Linux 9.1
  • MandrakeSoft Mandrake Linux 9.1 PPC
  • MandrakeSoft Mandrake Linux Corporate Server 2.1 X86_64
  • MandrakeSoft Mandrake Linux Corporate Server 2.1
  • MandrakeSoft Mandrake Multi Network Firewall 8.2
  • OpenPKG OpenPKG 1.1
  • OpenPKG OpenPKG 1.2
  • OpenPKG OpenPKG CURRENT
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Enterprise Linux 2.1 ES
  • RedHat Enterprise Linux 2.1 AW
  • RedHat Enterprise Linux 2.1 WS
  • RedHat Linux 7
  • RedHat Linux 7.1
  • RedHat Linux 7.1 for iSeries
  • RedHat Linux 7.1 for pSeries
  • RedHat Linux 7.2
  • RedHat Linux 7.3
  • RedHat Linux 8.0
  • RedHat Linux 9.0
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • SCO Caldera OpenLinux Server 3.1.1
  • SCO Caldera OpenLinux Workstation 3.1.1
  • Slackware Slackware Linux 9.0
  • Slackware Slackware Linux current
  • Turbolinux Turbolinux 7 Server
  • Turbolinux Turbolinux 7 Workstation
  • Turbolinux Turbolinux 8 Server
  • Turbolinux Turbolinux 8 Workstation
  • Turbolinux Turbolinux Advanced Server 6
  • Turbolinux Turbolinux Server 6.1
  • Turbolinux Turbolinux Server 6.5
  • Turbolinux Turbolinux Workstation 6.0

Reported:

May 09, 2003

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page