Linux kernel hash table collision packets denial of service

linux-kernel-packets-dos (12160) The risk level is classified as MediumMedium Risk

Description:

The Linux Kernel is vulnerable to a denial of service, caused by improper handling of TCP/IP fragment reassembly. A remote attacker could send specially-crafted packets that would cause a large number of hash table collisions, which would consume all available CPU resources.


Consequences:

Denial of Service

Remedy:

For Red Hat Linux:
Upgrade to the latest kernel packages, as listed below. Refer to RHSA-2003:187-25, RHSA-2003:190-25, RHSA-2003:195-06, and RHSA-2003:198-16 for more information. See References.

Red Hat 7.1, 7.2 and 7.3: 2.4.20-18.7 or later
Red Hat 8.0: 2.4.20-18.8 or later
Red Hat 9.0: 2.4.20-18.9 or later
Red Hat Enterprise Linux AS (v. 2.1) and Red Hat Linux Advanced Workstation 2.1 for the Itanium Processor: 2.4.18-e37 or later

For Debian GNU/Linux 3.0 (woody):
Upgrade to the latest kernel package (2.2.20-5woody2 or 2.2.20-5woody3 or later), as listed in DSA-336-1. See References.

For Debian GNU/Linux 3.0 (woody):
Upgrade to the latest kernel powerpc package (2.4.18-1woody1 or later), as listed in DSA-312-1. See References.

For Debian GNU/Linux 3.0 (woody) containing the linux-kernel-2.4.17-s390 package:
Upgrade to the latest kernel package (0.0.20020816-0.woody.2 or later), as listed in DSA-442-1. See References.

For Turbolinux:
Upgrade to the latest kernel package, as listed below. Refer to Turbolinux Security Advisory TLSA-2003-41 for more information. See References.

Turbolinux: 2.4.18-13 or later

For Conectiva Linux 8:
Upgrade to the latest version of kernel (2.4.19-1U80_18cl or later), as listed in Conectiva Linux Security Announcement CLSA-2003:796. See References.

For Conectiva Linux 9:
Upgrade to the latest version of kernel (2.4.21-31301U90_4cl or later), as listed in Conectiva Linux Security Announcement CLSA-2003:702. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 8.0
  • Conectiva Linux 9.0
  • Debian Debian Linux 3.0
  • Linux Kernel 2.4.0
  • RedHat Enterprise Linux 2.1 ES
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Enterprise Linux 2.1 AW
  • RedHat Enterprise Linux 2.1 WS
  • RedHat Linux 7.1
  • RedHat Linux 7.1 for iSeries
  • RedHat Linux 7.1 for pSeries
  • RedHat Linux 7.2
  • RedHat Linux 7.3
  • RedHat Linux 8.0
  • RedHat Linux 9.0
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • Turbolinux Turbolinux 7 Server
  • Turbolinux Turbolinux 7 Workstation
  • Turbolinux Turbolinux 8 Server
  • Turbolinux Turbolinux 8 Workstation

Reported:

Jun 03, 2003

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page