PHPRecipeBook recipe cross-site scripting

phprecipebook-recipe-xss (13574) The risk level is classified as MediumMedium Risk

Description:

PHPRecipeBook is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. A remote attacker could post a recipe containing malicious HTML or script code, which would be executed in the victim's Web browser, when the recipe is viewed.


Consequences:

Obtain Information

Remedy:

Upgrade to the latest version of PHPRecipeBook (2.18 or later), available from the PHPRecipeBook Web page. See References.

References:

  • PHPRecipeBook Web page: PHP RecipeBook.
  • BID-8963: PHPRecipeBook Unspecified Cross-Site Scripting/HTML Injection Vulnerabilities
  • CVE-2003-1190: Cross-site scripting (XSS) vulnerability in PHPRecipeBook 1.24 through 2.17 allows remote attackers to inject arbitrary web script or HTML via a recipe.
  • OSVDB ID: 2755: PHPRecipeBook Recipe XSS
  • SA10109: PHPRecipeBook Cross-Site Scripting Vulnerability

Platforms Affected:

  • Todd Rogers PHPRecipeBook prior to 2.18

Reported:

Nov 03, 2003

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page