Ethereal ISAKMP and MEGACO packet buffer overflow

ethereal-isakmp-megaco-bo (13577) The risk level is classified as MediumMedium Risk

Description:

Ethereal is vulnerable to a denial of service, caused by a buffer overflow. A remote attacker could create a malformed ISAKMP or MEGACO packet to overflow a buffer and cause Ethereal to crash.


Consequences:

Denial of Service

Remedy:

Upgrade to the latest version of Ethereal (0.9.16 or later), as listed in Ethereal Application Note enpa-sa-00011. See References.

As a workaround, disable the ISAKMP and MEGACO protocol dissectors.

For Conectiva Linux:
Upgrade to the latest ethereal package, as listed below. Refer to Conectiva Linux Security Announcement CLSA-2003:780 for more information. See References.

Conectiva Linux 7.0: 0.9.16-1U70_1cl or later
Conectiva Linux 8: 0.9.16-1U80_1cl or later
Conectiva Linux 9: 0.9.16-2709U90_1cl or later

For Red Hat Linux:
Upgrade to the latest ethereal package, as listed below. Refer to RHSA-2003:323-07 for more information. See References.

Red Hat 7.2: 0.9.16-0.72.1 or later
Red Hat 7.3: 0.9.16-0.73.1 or later
Red Hat 8.0: 0.9.16-0.80.1 or later
Red Hat 9: 0.9.16-0.90.1 or later

For Red Hat Linux containing the ethereal package:
Upgrade to the latest ethereal package, as listed below. Refer to RHSA-2003:324-09 for more information. See References.

Red Hat Enterprise Linux AS (v. 2.1) (v. 3), ES (v.2.1) (v. 3), WS (v.2.1) (v. 3), and Red Hat Linux Advanced Workstation 2.1 for the Itanium Processor and (v. 3): 0.9.16-0.AS21.1 or 0.9.16-0.30E.1 or later

For Gentoo Linux:
Upgrade to the latest version of ethereal (0.9.16 or later), as listed in Gentoo Linux Security Announcement 200311-04. See References.

For Turbolinux:
Upgrade to the latest ethereal package (0.9.16-1 or later), as listed in Turbolinux Security Advisory TLSA-2003-64. See References.

For Mandrake Linux:
Upgrade to the latest ethereal package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2003:114 : ethereal for more information. See References.

Mandrake Linux 9.1: 0.9.16-2.1.91mdk or later
Mandrake Linux 9.2: 0.9.16-2.1.92mdk or later

For Debian GNU/Linux 3.0 (woody):
Upgrade to the latest version of ethereal (0.9.4-1woody6 or later), as listed in DSA-407-1. See References.

For Conectiva Linux:
Upgrade to the latest Ethereal package, as listed below. Refer to Conectiva Linux Announcement CLSA-2005:1003 for more information. See References.

Conectiva Linux 10.0: 0.10.12-77079U10_5cl or later

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 10
  • Conectiva Linux 7.0
  • Conectiva Linux 8.0
  • Conectiva Linux 9.0
  • Debian Debian Linux 3.0
  • Ethereal Ethereal 0.9.15
  • Gentoo Linux
  • MandrakeSoft Mandrake Linux 9.1
  • MandrakeSoft Mandrake Linux 9.1 PPC
  • MandrakeSoft Mandrake Linux 9.2
  • RedHat Enterprise Linux 2.1 AW
  • RedHat Enterprise Linux 2.1 WS
  • RedHat Enterprise Linux 2.1 ES
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Enterprise Linux 3 ES
  • RedHat Enterprise Linux 3 WS
  • RedHat Enterprise Linux 3 AS
  • RedHat Linux 7.2
  • RedHat Linux 7.3
  • RedHat Linux 8.0
  • RedHat Linux 9.0
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • Turbolinux Turbolinux 10 Desktop

Reported:

Nov 03, 2003

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page