Linux rsync heap overflow

linux-rsync-heap-overflow (13899) The risk level is classified as HighHigh Risk

Description:

rsync is vulnerable to a heap overflow, caused by improper bounds checking. A remote attacker could exploit this vulnerability to execute arbitrary code on the system with privileges of rsync.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of rsync (2.5.7 or later), available from the rsync download Web page. See References.

For Slackware Linux:
Upgrade to the latest rsync package, as listed below. Refer to slackware-security Mailing List, Wed, 3 Dec 2003 23:50:44 -0800 (PST) for more information. See References.

Slackware Linux 8.1, 9.0, 9.1, and -current: 2.5.7-i386-1 or later

For Trustix Secure Linux 1.2, 1.5, and 2.0:
Upgrade to the latest rsync package (2.5.7-1tr or later), as listed in Trustix Secure Linux Security Advisory #2003-0048. See References.

For Red Hat Linux:
Upgrade to the latest rsync package, as listed below. Refer to RHSA-2003:398-07 for more information. See References.

Red Hat 7.1, 7.2, and 7.3: 2.5.7-0.7 or later
Red Hat 8.0: 2.5.7-0.8 or later
Red Hat 9: 2.5.7-0.9 or later

For Red Hat Linux containing the rsync package:
Upgrade to the latest rsync package, as listed below. Refer to RHSA-2003:399-06 for more information. See References.

Red Hat Enterprise Linux AS (v. 2.1), ES (v. 2.1), WS (v. 2.1), and Red Hat Linux Advanced Workstation 2.1 for the Itanium Processor: 2.5.7-0.7 or later

Red Hat Enterprise Linux AS (v. 3), ES (v. 3), and WS (v. 3): 2.5.7-1 or later

For SuSE Linux:
Upgrade to the latest rsync package, as listed below. Refer to SuSE Security Announcement SuSE-SA:2003:050 for more information. See References.

SuSE Linux 9.0 and 8.2 (Intel): 2.5.6-193 or later
SuSE Linux 8.1: 2.5.5-258 or later
SuSE Linux 8.0 and 7.3: 2.4.6-499 or later
SuSE Linux 7.3 (Sparc): 2.4.6-190 or later
SuSE Linux 7.3 (PPC): 2.4.6-309 or later

For Conectiva Linux:
Upgrade to the latest rsync package, as listed below. Refer to Conectiva Linux Security Announcement CLSA-2003:794 for more information. See References.

Conectiva Linux 8: 2.5.7-5U80_1cl or later
Conectiva Linux 9: 2.5.7-13508U90_1cl or later

For Mandrake Linux:
Upgrade to the latest rsync package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2003:111 : rsync for more information. See References.

Mandrake Linux 9.0: 2.5.5-5.1.90mdk or later
Mandrake Linux 9.1: 2.5.7-0.1.91mdk or later
Mandrake Linux 9.2: 2.5.7-0.1.92mdk or later
Mandrake Linux Multi Network Firewall 8.2: 2.5.4-2.1.M82mdk or later
Mandrake Linux Corporate Server 2.1: 2.5.5-5.1.C21mdk or later

For Gentoo Linux:
Upgrade to the latest version of rsync (2.5.7 or later), as listed in Gentoo Linux Security Announcement 200312-03. See References.

For EnGarde Secure Linux Community Edition and Professional Edition:
Upgrade to the latest rsync package (2.4.6-1.0.7 or later), as listed in Guardian Digital Security Advisory ESA-20031204-032. See References.

For OpenPKG:
Upgrade to the latest rsync package, as listed below. Refer to OpenPKG Security Advisory OpenPKG-SA-2003.051 for more information. See References.

OpenPKG CURRENT: 2.5.7-20031204 or later
OpenPKG 1.2: 2.5.5-1.2.1 or later
OpenPKG 1.3: 2.5.6-1.3.1 or later

For Turbolinux:
Upgrade to the latest rsync package (2.5.7-1 or later), as listed in Turbolinux Security Advisory TLSA-2003-67. See References.

For Immunix:
Upgrade to the latest rsync package, as listed below. Refer to Immunix Secured OS Security Advisory IMNX-2003-73-001-01 for more information. See References.

Immunix 7.3: 2.5.4-2_imnx_2 or later
Immunix 7+: 2.5.2-2_imnx_1 or later

For SGI IRIX:
Apply the 10037 patch for this vulnerability, as listed in SGI Security Advisory 20031202-01-U. See References.

For Debian GNU/Linux:
Upgrade to the latest rsync package, as listed below. Refer to DSA-404-1 for more information. See References.

Debian GNU/Linux 3.0 (Woody): 2.5.5-0.2 or later

For Mac OS X:
Upgrade to Security Update 2003-12-19 as recommended in AppleCare Knowledge Base Document 61798. See References.

For Caldera OpenLinux 3.1.1 (Workstation and Server):
Upgrade to the latest version of rsync (2.5.7-1 or later), as listed in SCO Security Advisory CSSA-2004-010.0. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 8.0
  • Conectiva Linux 9.0
  • Debian Debian Linux 3.0
  • EngardeLinux Secure Community 1.0.1
  • EngardeLinux Secure Community 2.0
  • EngardeLinux Secure Professional 1.1
  • EngardeLinux Secure Professional 1.2
  • EngardeLinux Secure Professional 1.5
  • EngardeLinux Security Community
  • Gentoo Linux
  • GNU rsync prior to 2.5.7
  • Immunix Immunix OS 7+-beta
  • Immunix Immunix OS 7.3
  • MandrakeSoft Mandrake Linux 9.0
  • MandrakeSoft Mandrake Linux 9.1
  • MandrakeSoft Mandrake Linux 9.1 PPC
  • MandrakeSoft Mandrake Linux 9.2 AMD64
  • MandrakeSoft Mandrake Linux 9.2
  • MandrakeSoft Mandrake Linux Corporate Server 2.1
  • MandrakeSoft Mandrake Linux Corporate Server 2.1 X86_64
  • MandrakeSoft Mandrake Multi Network Firewall 8.2
  • Novell SuSE Linux Enterprise Server 7.0
  • OpenPKG OpenPKG 1.2
  • OpenPKG OpenPKG 1.3
  • OpenPKG OpenPKG CURRENT
  • RedHat Enterprise Linux 2.1 AW
  • RedHat Enterprise Linux 2.1 WS
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Enterprise Linux 2.1 ES
  • RedHat Enterprise Linux 3 WS
  • RedHat Enterprise Linux 3 ES
  • RedHat Enterprise Linux 3 AS
  • RedHat Linux 7
  • RedHat Linux 7.1
  • RedHat Linux 7.2
  • RedHat Linux 7.3
  • RedHat Linux 8.0
  • RedHat Linux 9.0
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • SCO Caldera OpenLinux Server 3.1.1
  • SCO Caldera OpenLinux Workstation 3.1.1
  • Slackware Slackware Linux 8.1
  • Slackware Slackware Linux 9.0
  • Slackware Slackware Linux 9.1
  • Slackware Slackware Linux current
  • SuSE Linux Enterprise Server 8
  • SuSE SuSE eMail Server 3.1
  • SuSE SuSE eMail Server III
  • SUSE SuSE Linux 7.3
  • SUSE SuSE Linux 8.0
  • SUSE SuSE Linux 8.1
  • SUSE SuSE Linux 8.2
  • SUSE SuSE Linux 9.0
  • SuSE SuSE Linux Connectivity Server
  • SuSE SuSE Linux Database Server
  • SuSE SuSE Linux Firewall
  • SuSE SuSE Linux Office Server
  • Trustix Secure Linux 1.2
  • Trustix Secure Linux 1.5
  • Trustix Secure Linux 2.0
  • Turbolinux Turbolinux 10 Desktop
  • Turbolinux Turbolinux 7 Server
  • Turbolinux Turbolinux 7 Workstation
  • Turbolinux Turbolinux 8 Server
  • Turbolinux Turbolinux 8 Workstation
  • Turbolinux Turbolinux Advanced Server 6
  • Turbolinux Turbolinux Server 6.1
  • Turbolinux Turbolinux Server 6.5
  • Turbolinux Turbolinux Workstation 6.0

Reported:

Oct 04, 2003

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page