FSP boundary error buffer overflow
|fsp-boundry-error-bo (14155)||High Risk|
FSP Suite (File Service Protocol) is vulnerable to a buffer overflow, caused by improper bounds checking. A remote attacker could exploit this vulnerability to overflow a buffer and execute arbitrary code on the system.
Upgrade to the latest version of FSP Suite (2.8.1b18 or later), available from the FSP Suite Web page. See References.
For Debian GNU/Linux 3.0 (woody):
Upgrade to the latest fsp package (2.81.b3-3.1woody1 or later), as listed in DSA-416-1. See References.
For other distributions:
Contact your vendor for upgrade or patch information.
- CIAC Information Bulletin O-048: Debian fsp Buffer Overflow Vulnerability.
- FSP CVS ChangeLog Web page: Version 2.8.1b18 - 25 Nov 24 2003.
- BID-9377: Debian FSP Vulnerabilities
- CVE-2004-0011: Buffer overflow in fsp before 2.81.b18 allows remote users to execute arbitrary code.
- DSA-416: fsp -- buffer overflow
- OSVDB ID: 6852: FSP Remote Overflow
- Debian Debian Linux 3.0
- FSP Opensource Community FSP Suite 2.8.1b18 and prior
Nov 24, 2003
The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.
For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this