vbox3 tcl privilege escalation

vbox3-tcl-privilege-escalation (14170) The risk level is classified as HighHigh Risk

Description:

vbox3 could allow a local attacker to gain elevated privileges on the system, caused by the failure to drop privileges prior to execution by the tcl script. A local attacker could exploit this vulnerability to gain root privileges on the vulnerable system.


Consequences:

Gain Privileges

Remedy:

Upgrade to the latest version of vbox3 (0.1.7.1 or later), available from the vbox3 Web site. See References.

For Debian GNU/Linux 3.0 (woody):
Upgrade to the latest vbox3 package (0.1.7.1 or later), as listed in DSA-418-1. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

  • vbox3 Web site: vbox3.
  • BID-9381: VBox3 For ISDN4Linux Local Privilege Escalation Vulnerability
  • CVE-2004-0015: vbox3 0.1.8 and earlier does not properly drop privileges before executing a user-provided TCL script, which allows local users to gain privileges.
  • DSA-418: vbox3 -- privilege leak
  • OSVDB ID: 34359: myFlash Plugin for WordPress myflash-button.php wpPATH Parameter Remote File Inclusion

Platforms Affected:

  • Debian Debian Linux 3.0
  • smarden.org vbox3 prior to 0.1.7.1

Reported:

Jun 04, 2003

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page