PhpDig remote includes/config.php PHP file include

phpdig-config-file-include (14826) The risk level is classified as MediumMedium Risk

Description:

PhpDig could allow a remote attacker to execute arbitrary code. A remote attacker could allow a remote attacker to include malicious PHP files, caused by improper validation of user-supplied input by the includes/config.php script. A remote attacker could send a specially-crafted URL request to a vulnerable system using the $relative_script_path variable to specify a malicious file from a remote system as a parameter, which would allow the attacker to execute code on the vulnerable system.


Consequences:

Gain Access

Remedy:

No remedy available as of September 1, 2014.

References:

  • BugTraq Mailing List, Wed Jan 14 2004 - 11:14:15 CST : PhpDig 1.6.x: remote command execution.
  • PhpDig Web page: kernelpaniklabs Web site.
  • BID-9424: PHPDig Config.PHP Include Remote Command Execution Vulnerability
  • CVE-2004-0068: PHP remote file inclusion vulnerability in config.php for PhpDig 1.6.5 and earlier allows remote attackers to execute arbitrary PHP code by modifying the $relative_script_path parameter to reference a URL on a remote web server that contains the code.
  • OSVDB ID: 3505: PhpDig config.php relative_script_path Parameter Remote File Inclusion

Platforms Affected:

  • kernalpaniklabs PhpDig 1.6.x

Reported:

Jan 14, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page