KDE Personal Information Management buffer overflow

kde-kdepim-bo (14833) The risk level is classified as HighHigh Risk

Description:

The KDE Personal Information Management (kdepim) suite could allow a local attacker to overflow a buffer, caused by a vulnerability in the VCF file information reader used by the kdepim suite. A local attacker could create a specially-crafted .VCF file to overflow a buffer and execute arbitrary code on the system or gain access to the information in the victim's personal information management account. If the preview option is enabled, a remote attacker may be able to gain access to the victim's account.


Consequences:

Gain Access

Remedy:

Apply the appropriate patch for your system, available from the K Desktop Environment (KDE) Web site. See References.

— OR —

As a workaround, remove the kfile_vcf.desktop file.

For Red Hat Linux:
Upgrade to the latest kdepim package, as listed below. Refer to RHSA-2004:006-04 for more information. See References.

Red Hat 9: 3.1-6 or later

For Mandrake Linux:
Upgrade to the latest kdepim package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-MDKSA-2004:003 : kdepim for more information. See References.

Mandrake Linux 9.1: 3.1-17.1.91mdk. or later
Mandrake Linux 9.2: 3.1.3-22.1.92mdk or later

For Slackware Linux:
Upgrade to the latest kdepim package, as listed below. Refer to slackware-security Mailing List, Wed, 14 Jan 2004 21:43:35 -0800 (PST) for more information. See References.

Slackware Linux 9.0: 3.1.3-i386-2 or later
Slackware Linux 9.1: 3.1.4-i486-2 or later
Slackware Linux current: 1.1.5-i486-1 or later

For Conectiva Linux:
Upgrade to the latest kdepim package, as listed below. Refer to Conectiva Linux Security Announcement CLSA-2004:810 for more information. See References.

Conectiva Linux 9: 3.1.1-27625U90_1cl or later

For Gentoo Linux:
Upgrade to the latest version of kde (3.1.5 or later), as listed in GLSA 200404-02. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 9.0
  • Gentoo Linux
  • KDE K Desktop Environment (KDE) 3.1.0 - 3.1.4
  • MandrakeSoft Mandrake Linux 9.0
  • MandrakeSoft Mandrake Linux 9.1
  • MandrakeSoft Mandrake Linux 9.1 PPC
  • MandrakeSoft Mandrake Linux 9.2 AMD64
  • MandrakeSoft Mandrake Linux 9.2
  • RedHat Enterprise Linux 3 ES
  • RedHat Enterprise Linux 3 AS
  • RedHat Enterprise Linux 3 WS
  • RedHat Linux 9.0
  • Slackware Slackware Linux 9.0
  • Slackware Slackware Linux 9.1
  • Slackware Slackware Linux current
  • Turbolinux Turbolinux 10 Desktop

Reported:

Jan 14, 2003

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page