suidperl information disclosure

suidperl-obtain-information (15012) The risk level is classified as MediumMedium Risk

Description:

suidperl contains multiple vulnerabilities that could allow a local attacker to obtain sensitive information.


Consequences:

Obtain Information

Remedy:

For Debian Linux 3.0 (woody):
Upgrade to the latest version of perl (5.6.1-8.6 or later), as listed in DSA 431-1. See References.

References:

  • DSA 431-1: perl - information leak.
  • BID-9543: Suidperl Unspecified Information Disclosure Vulnerability
  • CVE-2003-0618: Multiple vulnerabilities in suidperl 5.6.1 and earlier allow a local user to obtain sensitive information about files for which the user does not have appropriate permissions.
  • DSA-431: perl -- information leak
  • OSVDB ID: 6103: Perl suidperl File Information Leak

Platforms Affected:

  • Debian Debian Linux 3.0
  • suidperl suidperl

Reported:

Feb 01, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page