util-linux information leak

utillinux-information-leak (15016) The risk level is classified as MediumMedium Risk

Description:

The util-linux package included with Red Hat Enterprise Linux AS, ES, WS, and Advanced Workstation could allow a local attacker to obtain sensitive information, caused by a vulnerability in the login program. The login program may leak information caused by a pointer that has been freed and reallocated. A local attacker could exploit this vulnerability to obtain sensitive information.


Consequences:

Obtain Information

Remedy:

For Red Hat Linux:
Upgrade to the latest util-linux package, as listed below. Refer to RHSA-2004:056-05 for more information. See References.

Red Hat Enterprise Linux AS (v. 2.1): 2.11f-20.4 or later

Red Hat Enterprise Linux ES (v. 2.1): 2.11f-20.4 or later

Red Hat Enterprise Linux WS (v. 2.1): 2.11f-20.4 or later

Red Hat Linux Advanced Workstation 2.1 for the Itanium Processor: 2.11f-20.4 or later

For Caldera OpenLinux 3.1.1 (Workstation and Server):
Upgrade to the latest version of util-linux (2.12-1 or later), as listed in SCO Security Advisory CSSA-2004-016.0. See References.

For Gentoo Linux:
Upgrade to the latest version of util-linux (2.12 or later), as listed in Gentoo Security Advisory GLSA 200404-06. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Gentoo Linux
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Enterprise Linux 2.1 AW
  • RedHat Enterprise Linux 2.1 WS
  • RedHat Enterprise Linux 2.1 ES
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • SCO Caldera OpenLinux Server 3.1.1
  • SCO Caldera OpenLinux Workstation 3.1.1

Reported:

Feb 03, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page