X-Cart perl_binary variable command execution

xcart-perlbinary-execute-commands (15034) The risk level is classified as HighHigh Risk

Description:

X-Cart could allow a remote attacker to execute arbitrary commands on the system, caused by a vulnerability in the perl_binary variable. A remote attacker could send a specially-crafted URL request containing commands in the perl_binary variable of multiple scripts, including the upgrade.php script and the general.php script, which would allow the attacker to execute commands on the system with privileges of the Web server.


Consequences:

Gain Access

Remedy:

Apply the appropriate patches for your system, available from the X-Cart Web site. See References.

References:

Platforms Affected:

  • Qualiteam X-Cart 3.4.3

Reported:

Feb 03, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page