GNU Mailman command handler denial of service

mailman-command-handler-dos (15106) The risk level is classified as MediumMedium Risk

Description:

GNU Mailman is vulnerable to a denial of service, caused by a vulnerability in the mail command handler. A remote attacker could use this vulnerability to cause a denial of service.


Consequences:

Denial of Service

Remedy:

Upgrade to the latest version of GNU Mailman (2.0.14 or later), available from the SourceForge.net Web site. See References.

For Red Hat Linux containing mailman package:
Upgrade to the latest mailman package, as listed below. Refer to RHSA-2004:156-07 for more information. See References.

Red Hat Enterprise Linux AS (v. 2.1), ES (v.2.1), and Advanced Workstation for the Itanium Processor: 2.0.13-6 or later

For Mandrake Linux:
Upgrade to the latest mailman package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2004:013 : mailman for more information. See References.

Mandrake Linux 9.1: 2.0.14-1.1.91mdk or later
Mandrake Linux 9.2: 2.1.2-9.3.92mdk or later
Mandrake Linux Corporate Server 2.1: 2.0.14-1.1.C21mdk or later

For Conectiva Linux:
Upgrade to the latest mailman package, as listed below. Refer to Conectiva Linux Security Announcement CLSA-2004:842 for more information. See References.

Conectiva Linux 8: 2.0.14-1U80_1cl or later
Conectiva Linux 9: 2.1.4-27744U90_2cl or later

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 8.0
  • Conectiva Linux 9.0
  • Debian Debian Linux 3.0
  • GNU Mailman 1.0
  • GNU Mailman 1.1
  • GNU Mailman 2.0 Beta5
  • GNU Mailman 2.0 Beta4
  • GNU Mailman 2.0 Beta3
  • GNU Mailman 2.0
  • GNU Mailman 2.0.1
  • GNU Mailman 2.0.10
  • GNU Mailman 2.0.11
  • GNU Mailman 2.0.12
  • GNU Mailman 2.0.13
  • GNU Mailman 2.0.2
  • GNU Mailman 2.0.3
  • GNU Mailman 2.0.4
  • GNU Mailman 2.0.5
  • GNU Mailman 2.0.6
  • GNU Mailman 2.0.7
  • GNU Mailman 2.0.8
  • GNU Mailman 2.0.9
  • GNU Mailman 2.1
  • MandrakeSoft Mandrake Linux 9.1
  • MandrakeSoft Mandrake Linux 9.2
  • MandrakeSoft Mandrake Linux Corporate Server 2.1
  • Novell SuSE Linux Enterprise Server 7.0
  • Novell UnitedLinux 1.0
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Enterprise Linux 2.1 ES
  • RedHat Enterprise Linux 2.1 AW
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • SGI ProPack 2.3
  • SUSE SuSE Linux 8.1
  • SUSE SuSE Linux 9.0
  • SuSE SuSE Linux Connectivity Server
  • SuSE SuSE Linux Database Server
  • SuSE SuSE Linux Office Server

Reported:

Feb 08, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page