PHP-Nuke Search and Web_links modules SQL injection

phpnuke-modules-sql-injection (15115) The risk level is classified as MediumMedium Risk

Description:

PHP-Nuke is vulnerable to SQL injection, caused by a vulnerability in the Search module and in the Web_links module. A remote attacker could insert arbitrary SQL code in the $category variable in a request to the index.php script of the Search module or in the $admin variable in a request to multiple scripts in the Web_links module, which would allow the attacker obtain sensitive information, including the administrator's MD5 password hash, allowing the attacker to add, modify or delete data in the backend database.


Consequences:

Data Manipulation

Remedy:

No remedy available as of August 1, 2014.

References:

  • PHP-Nuke Web site: PHP-Nuke.
  • Scan Associates Advisory 10 February 2004: PHPNuke 6.9 > and below (posibbly 7.x) SQL Injection in multiple module..
  • BID-9630: PHPNuke Category Parameter SQL Injection Vulnerability
  • CVE-2004-0269: SQL injection vulnerability in PHP-Nuke 6.9 and earlier, and possibly 7.x, allows remote attackers to inject arbitrary SQL code and gain sensitive information via (1) the category variable in the Search module or (2) the admin variable in the Web_Links module.
  • OSVDB ID: 3929: PHP-Nuke Web_Links Module admin Parameter SQL Injection
  • OSVDB ID: 3930: PHP-Nuke Search Module category Parameter SQL Injection

Platforms Affected:

  • PHPNuke PHP-Nuke 6.0
  • PHPNuke PHP-Nuke 6.5 rc2
  • PHPNuke PHP-Nuke 6.5 rc1
  • PHPNuke PHP-Nuke 6.5 rc3
  • PHPNuke PHP-Nuke 6.5 beta1
  • PHPNuke PHP-Nuke 6.5 Final
  • PHPNuke PHP-Nuke 6.5
  • PHPNuke PHP-Nuke 6.6
  • PHPNuke PHP-Nuke 6.7
  • PHPNuke PHP-Nuke 6.8
  • PHPNuke PHP-Nuke 6.9

Reported:

Feb 10, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page