ezContents multiple .php PHP file include

ezcontents-multiple-file-include (15135) The risk level is classified as MediumMedium Risk

Description:

ezContents could allow a remote attacker to include malicious PHP files. A remote attacker could send a specially-crafted URL request to the modules.php, db.php, or archivednews.php scripts that specifies a malicious file from a remote system as a parameter, which would allow the attacker to execute code on the vulnerable system.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of ezContents (2.0.3 or later), available from the ezContents Web site. See References.

References:

  • BID-9638: VisualShapers ezContents Multiple Module File Include Vulnerability
  • CVE-2004-0132: Multiple PHP remote file inclusion vulnerabilities in ezContents 2.0.2 and earlier allow remote attackers to execute arbitrary PHP code from a remote web server, as demonstrated using (1) the GLOBALS[rootdp] parameter to db.php, or (2) the GLOBALS[language_home] parameter to archivednews.php, and a malicious version of lang_admin.php.
  • OSVDB ID: 3912: ezContents db.php Arbitrary File Inclusion
  • OSVDB ID: 3913: ezContents archivednews.php Arbitrary File Inclusion

Platforms Affected:

  • VisualShapers ezContents 2.02

Reported:

Feb 11, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page