phpCodeCabinet multiple scripts cross-site scripting

phpcodecabinet-multiple-xss (15190) The risk level is classified as MediumMedium Risk

Description:

phpCodeCabinet is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. A remote attacker could embed malicious script in certain parameters in multiple scripts, which would be executed in the victim's Web browser within the security context of the hosting site, once the link is clicked.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of phpCodeCabinet (0.5 or later), available from the SourceForge.net Web site. See References.

References:

  • phpCodeCabinet Web site: phpCodeCabinet - Code Reference Library.
  • SourceForge.net: SourceForge.net: File Release Notes and Changelog.
  • BID-9601: Brad Fears PHPCodeCabinet comments.php HTML Injection Vulnerability
  • BID-9645: PHPCodeCabinet Multiple Cross-Site Scripting Vulnerabilities
  • CVE-2004-2085: Multiple cross-site scripting (XSS) vulnerabilities in Brad Fears phpCodeCabinet 0.4 and earlier allow remote attackers to inject arbitrary web script or HTML via multiple parameters, including (1) the sid parameter to comments.php, (2) the cid, cf, or rfd parameters to category.php, or the cid parameter to (3) input.php, (4) browse.php, (5) themes/facade/header.php, or (6) themes/phpcc/header.php.
  • OSVDB ID: 16710: phpCodeCabinet (phpCC) facade/header.php Script Injection
  • OSVDB ID: 16711: phpCodeCabinet (phpCC) phpcc/header.php XSS
  • OSVDB ID: 3885: phpCodeCabinet (phpCC) comments.php XSS
  • OSVDB ID: 3886: phpCodeCabinet (phpCC) category.php XSS
  • OSVDB ID: 3887: phpCodeCabinet (phpCC) input.php XSS
  • OSVDB ID: 3920: phpCodeCabinet (phpCC) browse.php XSS
  • SA10862: phpCodeCabinet Cross-Site Scripting Vulnerabilities
  • SECTRACK ID: 1009012: phpCodeCabinet Input Validation Bugs Let Remote Users Conduct Cross-Site Scripting Attacks

Platforms Affected:

  • Brad Fears phpCodeCabinet 0.4

Reported:

Feb 12, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page