PWLib message denial of service

pwlib-message-dos (15202) The risk level is classified as MediumMedium Risk

Description:

PWLib (Portable Windows Library) is vulnerable to a denial of service. By creating a specially-crafted message, a remote attacker could cause a denial of service.


Consequences:

Denial of Service

Remedy:

Upgrade to the latest version of PWLib (1.6.0 or later), available from the OpenH323 Project Web site. See References.

For Red Hat Linux 9:
Upgrade to the latest pwlib package (1.4.7-4.1 or later), available from the RHSA-2004:048-03 for more information. See References.

For Red Hat Linux:
Upgrade to the latest pwlib package, as listed below. Refer to RHSA-2004:047-04 for more information. See References.

Red Hat Enterprise Linux AS (v. 3), ES (v. 3), and WS (v. 3): 1.4.7-7 or later

For Debian GNU/Linux:
Upgrade to the latest pwlib package, as listed below. Refer to DSA-448-1 for more information. See References.

Debian GNU/Linux 3.0 (woody): 1.2.5-5woody1

For Mandrake Linux:
Upgrade to the latest pwlib package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2004:017 : pwlib for more information. See References.

Mandrake Linux 9.1: 1.4.7-3.1.91mdk or later
Mandrake Linux 9.2: 1.5.0-15.1.92mdk or later

For Gentoo Linux:
Upgrade to the latest version of pwlib (1.5.2-r3 or later), as listed in GLSA 200404-11. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

  • GLSA 200404-11: Multiple Vulnerabilities in pwlib.
  • OpenH323 Project Web site: OpenH323 Project.
  • BID-9406: Multiple Vendor H.323 Protocol Implementation Vulnerabilities
  • CVE-2004-0097: Multiple vulnerabilities in PWLib before 1.6.0 allow remote attackers to cause a denial of service and possibly execute arbitrary code, as demonstrated by the NISCC/OUSPG PROTOS test suite for the H.225 protocol.
  • DSA-448: pwlib -- several vulnerabilities
  • GLSA-200404-11: Multiple Vulnerabilities in pwlib
  • MDKSA-2004:017: Updated pwlib packages fix vulnerability
  • RHSA-2004-047: pwlib security update
  • RHSA-2004-048: Updated PWLib packages fix protocol security issues
  • US-CERT VU#749342: Multiple vulnerabilities in H.323 implementations

Platforms Affected:

  • Debian Debian Linux 3.0
  • Gentoo Linux
  • MandrakeSoft Mandrake Linux 9.1
  • MandrakeSoft Mandrake Linux 9.1 PPC
  • MandrakeSoft Mandrake Linux 9.2
  • MandrakeSoft Mandrake Linux 9.2 AMD64
  • OpenH323 PWLib prior to 1.6.0
  • RedHat Enterprise Linux 3 AS
  • RedHat Enterprise Linux 3 ES
  • RedHat Enterprise Linux 3 WS
  • RedHat Linux 9.0

Reported:

Feb 13, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page