Sun Solaris passwd(1) allows elevated privileges

solaris-passwd-gain-privileges (15327) The risk level is classified as HighHigh Risk

Description:

Solaris could allow a local attacker to gain elevated privileges on the system, caused by a vulnerability in the passwd(1) command. A local attacker could use this vulnerability to gain elevated or root privileges on the system.


Consequences:

Gain Privileges

Remedy:

Apply the appropriate patch for your system, as listed below. Refer to Sun Alert ID: 57454 for more information. See References.

SPARC Platform:
Solaris 8 with patch: 108993-32 or later
Solaris 9 with patch: 113476-11 or later

x86 Platform:
Solaris 8 with patch: 108994-32 or later
Solaris 9 with patch: 114242-07 or later/P>

References:

Platforms Affected:

  • Sun Solaris 8 x86
  • Sun Solaris 8 SPARC
  • Sun Solaris 9 x86
  • Sun Solaris 9 SPARC

Reported:

Feb 26, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page