Calife long password buffer overflow

calife-long-password-bo (15335) The risk level is classified as HighHigh Risk

Description:

Calife is vulnerable to a buffer overflow, caused by improper bounds checking. By supplying a long password, a local attacker could overflow a buffer and cause a segmentation fault or possibly execute arbitrary code on the system.


Consequences:

Gain Privileges

Remedy:

Upgrade to the latest version of Calife (2.8.6 or later), when it becomes available from the Calife Web page. See References.

For Debian GNU/Linux 3.0 (woody):
Upgrade to the latest calife package (2.8.4c-1woody1 or later), as listed in DSA-461-1. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Calife Calife 2.8.4
  • Calife Calife 2.8.5
  • Debian Debian Linux 3.0

Reported:

Feb 27, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page