WinZip UUDeview package MIME buffer overflow

winzip-mime-bo (15336) The risk level is classified as HighHigh Risk

Description:

The WinZip utility is vulnerable to a buffer overflow in the UUDeview package when decoding long strings. By sending a specially-crafted MIME archive file, a remote attacker can overflow a buffer and execute arbitrary code on the system with privileges of the user running WinZip.

UUDeview, is also affected by this vulnerability.


Consequences:

Gain Access

Remedy:

For WinZip:
Upgrade to the latest version of WinZip (9.0 or later), available from the WinZip Web site. See References.

For UUDeview:
Upgrade to the latest version of UUDeview (0.5.20 or later), available from the UUDeview Web page. See References.

For Gentoo Linux:
Upgrade to the latest version of uudeview (0.5.20 or later), as listed in GLSA 200403-05. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Gentoo Linux
  • UUDeview UUDeview 0.5.19 and prior
  • WinZip WinZip 8.1

Reported:

Feb 27, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page