WFTPD Pro Server and Server FTP commands buffer overflow

wftpd-ftp-commands-bo (15340) The risk level is classified as HighHigh Risk

Description:

WFTPD Pro Server and WFTPD Server is vulnerable to a buffer overflow. An authenticated remote user could send a specially-crafted LIST, NLST or STAT command to the server to overflow a buffer and execute arbitrary code on the system.


Consequences:

Gain Privileges

Remedy:

Upgrade to the latest version of WFTDP (version 3.25 or later) available from the Texas Imperial Software Web site. See References.

References:

Platforms Affected:

  • Texas Imperial Software WFTPD Pro Server 3.20 R2
  • Texas Imperial Software WFTPD Pro Server 3.21 R1
  • Texas Imperial Software WFTPD Server 3.10 R1
  • Texas Imperial Software WFTPD Server 3.21 R1

Reported:

Feb 28, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page