phpBB viewtopic.php script allows cross-site scripting

phpbb-viewtopicphp-xss (15348) The risk level is classified as MediumMedium Risk

Description:

phpBB is vulnerable to cross-site scripting, caused by the improper filtering of user-supplied input in the viewtopic.php script. A remote attacker could embed malicious code in the postorder variable in a specially-crafted URL request to the viewtopic.php script, which would be executed in the victim's Web browser within the security context of the hosting site, once the link is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.


Consequences:

Gain Access

Remedy:

No remedy available as of September 1, 2014.

References:

  • BugTraq Mailing List, Sat Feb 28 2004 - 09:09:02 CST: New phpBB ViewTopic.php Cross Site Scripting Vulnerability.
  • phpBB Web site: phpBB.com :: Download phpBB.
  • BID-9765: PHPBB ViewTopic.PHP "postorder" Cross-Site Scripting Vulnerability
  • CVE-2004-0339: Cross-site scripting (XSS) vulnerability in ViewTopic.php in phpBB, possibly 2.0.6c and earlier, allows remote attackers to execute arbitrary script or HTML as other users via the postorder parameter.
  • OSVDB ID: 4256: phpBB viewtopic.php postorder Parameter XSS

Platforms Affected:

  • phpBB phpBB 2.0.6c

Reported:

Feb 29, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page