Apache HTTP Server mod_ssl plain HTTP request denial of service

apache-modssl-plain-dos (15419) The risk level is classified as MediumMedium Risk


Apache HTTP Server is vulnerable to a denial of service, caused by a memory leak in the mod_ssl authentication module. If a vulnerable server is enabled for SSL, a remote attacker could send plain HTTP requests to the SSL port to cause the daemon to crash.


Denial of Service


Upgrade to the latest version of Apache HTTP Server (2.0.49-dev or later), available from the Apache HTTP Server Web site. See References.

For Red Hat Linux:
Upgrade to the latest httpd package, as listed below. Refer to RHSA-2004:084-14 for more information. See References.

Red Hat Enterprise Linux AS (v. 3), ES (v. 3), and WS (v.3): 2.0.46-32 or later

For Red Hat Linux 9:
Upgrade to the latest httpd package (2.0.40-21.11 or later), as listed in RHSA-2004:182-03. See References.

For Trustix Secure Linux:
Upgrade to the latest apache package, as listed below. Refer to Trustix Secure Linux Security Advisory #2004-0017 for more information. See References.

Trustix Secure Linux 2.0: 2.0.49-2tr or later
Trustix Secure Linux 2.1: 2.0.49-2tr or later

For Turbolinux:
Upgrade to the latest httpd package, as listed below. Refer to Turbolinux Security Advisory TLSA-2004-11 for more information. See References.

Turbolinux 10 Desktop: 2.0.47-8 or later

For Conectiva Linux:
Upgrade to the latest apache package, as listed below. Refer to Conectiva Linux Security Announcement CLSA-2004:839. See References.

Conectiva Linux 8: 1.3.28-1U80_3cl or later
Conectiva Linux 9: 2.0.45-2879OU90_6cl or later

For Mandrake Linux:
Upgrade to the latest apache2 package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2004:043 : apache2 for more information. See References.

Mandrake Linux 9.1: 2.0.47-1.7.91mdk or later
Mandrake Linux 9.2: 2.0.47-6.4.92mdk or later
Mandrake Linux 10.0: 2.0.48-6.1.100mdk or later

For HP Tru64 UNIX 5.1B:
Apply the appropriate Early Release Patches (ERPs) for your system, as listed in HP Security Bulletin HPSBTU01049. See References.

For other distributions:
Apply the appropriate update for your system. See References.


Platforms Affected:

  • Apache HTTP Server 2.0.35
  • Apache HTTP Server 2.0.36
  • Apache HTTP Server 2.0.37
  • Apache HTTP Server 2.0.38
  • Apache HTTP Server 2.0.39
  • Apache HTTP Server 2.0.40
  • Apache HTTP Server 2.0.41
  • Apache HTTP Server 2.0.42
  • Apache HTTP Server 2.0.43
  • Apache HTTP Server 2.0.44
  • Apache HTTP Server 2.0.45
  • Apache HTTP Server 2.0.46
  • Apache HTTP Server 2.0.47
  • Apache HTTP Server 2.0.48
  • Compaq Tru64 5.1b
  • Conectiva Linux 8.0
  • Conectiva Linux 9.0
  • Gentoo Linux
  • MandrakeSoft Mandrake Linux 10.0
  • MandrakeSoft Mandrake Linux 10.0 AMD64
  • MandrakeSoft Mandrake Linux 9.1
  • MandrakeSoft Mandrake Linux 9.1 PPC
  • MandrakeSoft Mandrake Linux 9.2
  • MandrakeSoft Mandrake Linux 9.2 AMD64
  • Novell SuSE Linux Enterprise Server 7.0
  • Novell UnitedLinux 1.0
  • RedHat Enterprise Linux 3 AS
  • RedHat Enterprise Linux 3 ES
  • RedHat Enterprise Linux 3 WS
  • RedHat Linux 9.0
  • SUSE SuSE Linux 8.1
  • SUSE SuSE Linux 9.0
  • SUSE SuSE Linux 9.1
  • SuSE SuSE Linux Connectivity Server
  • SuSE SuSE Linux Database Server
  • SuSE SuSE Linux Office Server
  • Trustix Secure Linux 2.0
  • Trustix Secure Linux 2.1
  • Turbolinux Turbolinux 10 Desktop


Mar 09, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page