Apache HTTP Server mod_access information disclosure

apache-modaccess-obtain-information (15422) The risk level is classified as MediumMedium Risk

Description:

Apache HTTP Server could allow a remote user to obtain sensitive information, caused by a vulnerability in the mod_access module. When IP addresses are specified without a subnet netmask, the server may not use the proper Allow/Deny rule. A remote user could gain unauthorized access to files and directories, while other users could be denied access when these rules fail.


Consequences:

Obtain Information

Remedy:

Upgrade to the latest version of Apache HTTP Server (1.3.30-dev or later), available from the Apache HTTP Server Web site. See References.

For OpenBSD 3.3:
Apply the 019_httpd2.patch, available from the OpenBSD 3.3 errata Web site. See References.

For Slackware Linux:
Upgrade to the latest apache package, as listed below. Refer to slackware-security Mailing List, Wed, 12 May 2004 16:54:58 -0700 (PDT) for more information. See References.

Slackware Linux 8.1 and 9.0: 1.3.29-i386-2 or later
Slackware Linux 9.1: 1.3.29-i486-2 or later
Slackware Linux -current: 1.3.31-i486-1

For Trustix Secure Linux:
Upgrade to the latest apache package, as listed below. Refer to Trustix Secure Linux Security Advisory #2004-0027 for more information. See References.

Trustix Secure Linux 1.5: 1.3.31-1tr or later

For Mandrake Linux:
Upgrade to the latest apache package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2004:046 : apache for more information. See References.

Mandrake Linux 9.1: 1.3.27_1.3.4-7.1.91mdk or later
Mandrake Linux 9.2: 1.3.28_1.3.4-1.1.92mdk or later
Mandrake Linux Multi Network Firewall 8.2: 1.3.23-4.4.M82mdk or later
Mandrake Linux Corporate Server 2.1: 1.3.26-7.1.C21mdk or later
Mandrake Linux 10.0: 1.3.29-1.1.100mdk or later

For Gentoo Linux:
Upgrade to the latest version of apache (1.3.31 or later), as listed in GLSA 200405-22. See References.

For HP-UX B.11.04 with Virtualvault 4.7, Virtualvault 4.6, or Virtualvault 4.5:
Apply the appropriate patches for your system, as listed in HP Security Bulletin HPSBUX01069. See References.

For Sun Solaris:
Apply the appropriate patch for your system, as listed below. Refer to Sun Alert ID: 57628 for more information. See References.

SPARC Platform
Solaris 8 with patch 116973-01 or later
Solaris 9 with patch 113146-05 or later

x86 Platform
Solaris 8 with patch 116974-01 or later
Solaris 9 with patch 114145-04 or later

For OpenPKG:
Refer to OpenPKG Security Advisory OpenPKG-SA-2004.021 for patch, upgrade, or suggested workaround information. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Apache HTTP Server 1.3
  • Apache HTTP Server 1.3.1
  • Apache HTTP Server 1.3.11
  • Apache HTTP Server 1.3.12
  • Apache HTTP Server 1.3.14
  • Apache HTTP Server 1.3.17
  • Apache HTTP Server 1.3.18
  • Apache HTTP Server 1.3.19
  • Apache HTTP Server 1.3.20
  • Apache HTTP Server 1.3.22
  • Apache HTTP Server 1.3.23
  • Apache HTTP Server 1.3.24
  • Apache HTTP Server 1.3.25
  • Apache HTTP Server 1.3.26
  • Apache HTTP Server 1.3.27
  • Apache HTTP Server 1.3.28
  • Apache HTTP Server 1.3.29
  • Apache HTTP Server 1.3.3
  • Apache HTTP Server 1.3.4
  • Apache HTTP Server 1.3.6
  • Apache HTTP Server 1.3.7
  • Apache HTTP Server 1.3.9
  • Gentoo Linux
  • HP HP-UX 11.04
  • MandrakeSoft Mandrake Linux 10.0 AMD64
  • MandrakeSoft Mandrake Linux 10.0
  • MandrakeSoft Mandrake Linux 9.1
  • MandrakeSoft Mandrake Linux 9.1 PPC
  • MandrakeSoft Mandrake Linux 9.2
  • MandrakeSoft Mandrake Linux 9.2 AMD64
  • MandrakeSoft Mandrake Linux Corporate Server 1.0.1
  • MandrakeSoft Mandrake Linux Corporate Server 2.1
  • MandrakeSoft Mandrake Linux Corporate Server 2.1 X86_64
  • MandrakeSoft Mandrake Multi Network Firewall 8.2
  • Novell SuSE Linux Enterprise Server 7.0
  • Novell UnitedLinux 1.0
  • OpenBSD OpenBSD 3.3
  • OpenBSD OpenBSD 3.4
  • OpenPKG OpenPKG 1.3
  • OpenPKG OpenPKG 2.0
  • OpenPKG OpenPKG CURRENT
  • Slackware Slackware Linux 8.1
  • Slackware Slackware Linux 9.0
  • Slackware Slackware Linux 9.1
  • Slackware Slackware Linux current
  • Sun Solaris 8
  • Sun Solaris 9
  • SUSE SuSE Linux 9.0
  • SuSE SuSE Linux Connectivity Server
  • SuSE SuSE Linux Database Server
  • SuSE SuSE Linux Desktop 1.0
  • SuSE SuSE Linux Office Server
  • Trustix Secure Linux 1.5
  • Turbolinux Turbolinux 7 Server
  • Turbolinux Turbolinux 7 Workstation
  • Turbolinux Turbolinux 8 Server
  • Turbolinux Turbolinux 8 Workstation
  • Turbolinux Turbolinux Advanced Server 6
  • Turbolinux Turbolinux Appliance Server 1.0 Hosting Ed
  • Turbolinux Turbolinux Appliance Server 1.0 Workgroup Ed
  • Turbolinux Turbolinux Server 6.1
  • Turbolinux Turbolinux Server 6.5
  • Turbolinux Turbolinux Workstation 6.0

Reported:

Mar 08, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page