BEA WebLogic Server and Express unauthorized access to Web applications

weblogic-application-unauth-access (16123) The risk level is classified as MediumMedium Risk

Description:

BEA WebLogic Server and Express could allow a remote attacker to gain unauthorized access to Web applications. If weblogic.xml files are edited by Weblogic Builder or handled by the SecurityRoleAssignmentMBean.toxml function, security-role-assignment tags that do not contain principle-name tags, are deleted. A remote attacker could use this vulnerability to gain unauthorized access to Web applications.


Consequences:

Gain Access

Remedy:

For WebLogic Server and Express 8.1:
Upgrade to the latest Service Pack (2 or later) and apply the CR171885_810sp2.jar patch, as listed in BEA Systems Inc. Security Advisory: (BEA04-59.00). See References.

For WebLogic Server and Express 7.0:
Upgrade to the latest Service Pack (5 or later) and apply the CR171885_70sp5.jar patch, as listed in BEA Systems Inc. Security Advisory (BEA04-59.00). See References.

References:

  • BEA Systems, Inc. Security Advisory (BEA04-59.00): Patches are available to prevent unintended access to web applications.
  • BID-10328: BEA WebLogic Server And WebLogic Express Lowered Security Settings Vulnerability
  • CVE-2004-0470: BEA WebLogic Server and WebLogic Express 7.0 through SP5 and 8.1 through SP2, when editing weblogic.xml using WebLogic Builder or the SecurityRoleAssignmentMBean.toXML method, inadvertently removes security-role-assignment tags when weblogic.xml does not have a principal-name tag, which can remove intended access restrictions for the associated web application.
  • OSVDB ID: 6076: BEA WebLogic weblogic.xml Permission Reversion Weakness
  • SA11593: BEA WebLogic "weblogic.xml" May Reset to Default Permissions
  • SECTRACK ID: 1010128: BEA WebLogic `security-role-assignment` Coding Error May Delete Access Controls Tag
  • US-CERT VU#950070: BEA WebLogic Server contains vulnerability in handling of certain tags when editing weblogic.xml

Platforms Affected:

  • Oracle WebLogic Server 7.0 SP5
  • Oracle WebLogic Server 7.0 SP5 Express
  • Oracle WebLogic Server 8.1 SP2 Express
  • Oracle WebLogic Server 8.1 SP3
  • Oracle WebLogic Server 8.1 Express
  • Oracle WebLogic Server 8.1 SP1
  • Oracle WebLogic Server 8.1
  • Oracle WebLogic Server 8.1 SP1 Express

Reported:

May 11, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page