Ethereal MMSE dissector buffer overflow

ethereal-mmse-bo (16152) The risk level is classified as HighHigh Risk

Description:

Ethereal is vulnerable to a buffer overflow in the MMSE dissector. A remote attacker could exploit this vulnerability to overflow a buffer and execute arbitrary code on the system or cause Ethereal to crash.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of Ethereal (0.10.4 or later), when it becomes available from the Ethereal Web site. See References.

For SuSE Linux:
Apply the appropriate fixed packages via the SuSE FTP server or the YaST Online Update, as listed in SuSE Security Summary Report SUSE-SR:2004:002. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Ethereal Ethereal 0.10.1 - 0.10.3
  • Gentoo Linux
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Enterprise Linux 2.1 ES
  • RedHat Enterprise Linux 2.1 WS
  • RedHat Enterprise Linux 3 WS
  • RedHat Enterprise Linux 3 Desktop
  • RedHat Enterprise Linux 3 ES
  • RedHat Enterprise Linux 3 AS
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • SUSE SuSE Linux

Reported:

May 13, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page