PHP memory_limit code execution

php-memorylimit-code-execution (16693) The risk level is classified as HighHigh Risk

Description:

PHP could allow a remote attacker to execute arbitrary code on the server. If memory_limit support is enabled, a remote attacker could send a specially-crafted request to invoke the memory_limit

request termination where there is an unsafe interruption to execute arbitrary code on the PHP server.


Consequences:

Gain Access

Remedy:

For PHP4:
Upgrade to the latest version of PHP4 (4.3.8 or later), available from the PHP Web site. See References.

For PHP5:
Upgrade to the latest version of PHP5 (5.0.0 dated 13-Jul-2004 or later), available from the PHP Web site. See References.

For Mandrake Linux:
Upgrade to the latest php package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2004:068 : php for more information. See References.

Mandrake Linux 9.1: 430-11.2.91mdk or later
Mandrake Linux 9.2: 4.3.3-2.1.92mdk or later
Mandrake Linux Multi Network Firewall 8.2: 4.1.2-1.3.M82mdk or later
Mandrake Linux Corporate Server 2.1: 4.2.3-4.2.C21mdk or later
Mandrake Linux 10.0: 4.3.4-4.1.100mdk or later

For Gentoo Linux:
Upgrade to the latest version of php (4.3.8 or later), as listed in GLSA 200407-13. See References.

For SuSE Linux:
Upgrade to the latest php package, as listed below. Refer to SuSE Security Announcement SUSE-SA:2004:021 for more information. See References.

SuSE Linux 9.1: 4.3.4-43.11 or later
SuSE Linux 9.0: 4.3.3-177 or later
SuSE Linux 8.2: 4.3.1-169 or later
SuSE Linux 8.1: 4.2.2-479 or later
SuSE Linux 8.0: 4.1.0-317 or later

For Red Hat Linux:
Upgrade to the latest php package, as listed below. Refer to RHSA-2004:395-10 for more information. See References.

Red Hat Enterprise Linux AS (v. 2.1), ES (v. 2.1), WS (v. 2.1), and Red Hat Linux Advanced Workstation 2.1 for the Itanium Processor: 4.1.2-2.1.8 or later

For Red Hat Linux Stronghold:
Refer to RHSA-2005:816-10 for patch, upgrade, or suggested workaround information. See References.

For Conectiva Linux:
Upgrade to the latest php package, as listed below. Refer to Conectiva Linux Security Announcement CLSA-2004:847 for more information. See References.

Conectiva Linux 10: 4.3.6-63187U10_1cl or later
Conectiva Linux 8: 4.3.3-1U80_2cl or later
Conectiva Linux 9: 4.3.3-26997U90_3cl or later

For Slackware Linux:
Upgrade to the latest php package, as listed below. Refer to slackware-security Mailing List, Tue, 20 Jul 2004 23:21:16 -0700 (PDT) for more information. See References.

Slackware Linux 8.1and 9.0 : 4.3.8-i386-1 or later
Slackware Linux 9.1, 10.0 and -current: 4.3.8-i486-1 or later

For Debian GNU/Linux 3.0 (alias woody):
Upgrade to the latest php package (4.1.2-7 or later), as listed in DSA-531-1. See References.

For Debian GNU/Linux 3.0(woody):
Upgrade to the latest version of php3 (3.0.18-23.1woody2 or later), as listed in DSA-669-1. See References.

For OpenPKG:
Upgrade to the latest php package, as listed in OpenPKG Security Advisory OpenPKG-SA-2004.034-php. See References.

OpenPKG CURRENT: 4.3.8-20040714 or later
OpenPKG 2.0 : 4.3.4-2.0.1 or later

For Trustix Secure Linux:
Upgrade to the latest php package, as listed below. Refer to Trustix Secure Linux Security Advisory #2004-0039 for more information. See References.

For HP-UX 11.00, 11.11, 11.22, and 11.23:
Apply the appropriate patch for your system, as listed in Hewlett-Packard Company Security Bulletin HPSBUX01064. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 10
  • Conectiva Linux 8.0
  • Conectiva Linux 9.0
  • Debian Debian Linux 3.0
  • Gentoo Linux
  • MandrakeSoft Mandrake Linux 10.0 AMD64
  • MandrakeSoft Mandrake Linux 10.0
  • MandrakeSoft Mandrake Linux 9.1
  • MandrakeSoft Mandrake Linux 9.1 PPC
  • MandrakeSoft Mandrake Linux 9.2
  • MandrakeSoft Mandrake Linux 9.2 AMD64
  • MandrakeSoft Mandrake Linux Corporate Server 2.1
  • MandrakeSoft Mandrake Linux Corporate Server 2.1 X86_64
  • MandrakeSoft Mandrake Multi Network Firewall 8.2
  • Novell UnitedLinux 1.0
  • OpenPKG OpenPKG 2.0
  • OpenPKG OpenPKG 2.1
  • OpenPKG OpenPKG CURRENT
  • PHP PHP 4.0 RC2
  • PHP PHP 4.0 RC1
  • PHP PHP 4.0 Beta4
  • PHP PHP 4.0 Beta3
  • PHP PHP 4.0 Beta2
  • PHP PHP 4.0 Beta1
  • PHP PHP 4.0 Beta 4 Patch1
  • PHP PHP 4.0.0
  • PHP PHP 4.0.1
  • PHP PHP 4.0.2
  • PHP PHP 4.0.3
  • PHP PHP 4.0.4
  • PHP PHP 4.0.5
  • PHP PHP 4.0.6
  • PHP PHP 4.0.7
  • PHP PHP 4.1.0
  • PHP PHP 4.1.1
  • PHP PHP 4.1.2
  • PHP PHP 4.1.3
  • PHP PHP 4.2.0
  • PHP PHP 4.2.1
  • PHP PHP 4.2.2
  • PHP PHP 4.2.3
  • PHP PHP 4.2.4
  • PHP PHP 4.3.0
  • PHP PHP 4.3.1
  • PHP PHP 4.3.2
  • PHP PHP 4.3.3
  • PHP PHP 4.3.4
  • PHP PHP 4.3.5
  • PHP PHP 4.3.6
  • PHP PHP 4.3.7
  • PHP PHP 5.0.0 RC3
  • PHP PHP 5.0.0 RC2
  • PHP PHP 5.0.0 RC1
  • PHP PHP 5.0.0 Beta4
  • PHP PHP 5.0.0 Beta3
  • PHP PHP 5.0.0 Beta2
  • PHP PHP 5.0.0 Beta1
  • RedHat Enterprise Linux 2.1 WS
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Enterprise Linux 2.1 ES
  • RedHat Enterprise Linux 2.1 AW
  • RedHat Enterprise Linux 3 AS
  • RedHat Enterprise Linux 3 ES
  • RedHat Enterprise Linux 3 Desktop
  • RedHat Enterprise Linux 3 WS
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • RedHat Stronghold
  • Slackware Slackware Linux 8.1
  • Slackware Slackware Linux 9.0
  • Slackware Slackware Linux 9.1
  • Slackware Slackware Linux current
  • SuSE Linux Enterprise Server 8
  • SUSE SuSE Linux 8.0
  • SUSE SuSE Linux 8.1
  • SUSE SuSE Linux 8.2
  • SUSE SuSE Linux 9.0
  • SUSE SuSE Linux 9.1
  • SuSE SuSE Linux Office Server
  • Trustix Secure Enterprise Linux 2.0
  • Trustix Secure Linux 1.5
  • Trustix Secure Linux 2.0
  • Trustix Secure Linux 2.1

Reported:

Jul 13, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page