Adobe Acrobat Reader allows code execution

acrobat-reader-execute-code (16973) The risk level is classified as HighHigh Risk


Adobe Acrobat Reader is a program used for reading PDF files. Acrobat Reader versions 5.05 and 5.06 and possibly other versions running on Unix and Linux platforms could allow a remote attacker to execute arbitrary code on the system. The uudecode utility fails to properly filter the backtick shell metacharacter in the filenames. By creating a specially-crafted PDF file, a remote attacker could execute arbitrary code on the system, with user privileges, once the file is opened. A remote attacker could exploit this vulnerability by sending the malicious file to a victim in an email.


Gain Access


Upgrade to the latest version of Acrobat Reader (5.0.9 or later), available from the Adobe Systems Incorporated Downloads Web page. See References.

For Gentoo Linux:
Upgrade to the latest version of Acrobat Reader (5.09 or later), as listed in GLSA 200408-14. See References.

For Red Hat Linux:
Upgrade to the latest Acrobat Reader package, as listed below. Refer to RHSA-2004:432-08 for more information. See References.

Red Hat Enterprise Linux AS (v. 3), ES (v. 3), WS (v. 3), Desktop: 5.09-1 or later

For other distributions:
Contact your vendor for upgrade or patch information.


  • CIAC Information Bulletin 0-205: Adobe Acrobat Reader Uuencoding Buffer Overflow.
  • iDEFENSE Security Advisory 08.12.04: Adobe Acrobat Reader (Unix) Shell Metacharacter Code Execution Vulnerability.
  • BID-10931: Adobe Acrobat Reader Shell Metacharacter Remote Arbitrary Code Execution Vulnerability
  • CVE-2004-0630: The uudecoding feature in Adobe Acrobat Reader 5.0.5 and 5.0.6 for Unix and Linux, and possibly other versions including those before 5.0.9, allows remote attackers to execute arbitrary code via shell metacharacters (` or backtick) in the filename of the PDF file that is provided to the uudecode command.
  • GLSA-200408-14: acroread: UUDecode filename buffer overflow
  • RHSA-2004-432: acroread security update

Platforms Affected:

  • Adobe Acrobat Reader 5.0.5
  • Adobe Acrobat Reader 5.0.6
  • Gentoo Linux
  • RedHat Enterprise Linux 3 Desktop
  • RedHat Enterprise Linux 3 AS
  • RedHat Enterprise Linux 3 WS
  • RedHat Enterprise Linux 3 ES
  • RedHat RHEL Extras 3


Aug 12, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page