KDE Konqueror allows attacker to set cookies in top-level domains

kde-konqueror-cookie-set (17063) The risk level is classified as MediumMedium Risk

Description:

Konqueror could allow a remote attacker to set cookies within specific top-level domains (TLDs). By setting a cookie within the targeted user's Web browser for specific top-level domains, a remote attacker could cause Konqueror to send the cookies when connecting to any Web server within the same domain, and possibly allow the attacker to hijack the user's session.

Note: It is reported that all country TLDs that are greater than 2 characters within the secondary portion of the domain name are affected by this vulnerability, with the exception of those that use com, net, mil, org, gov, edu or int in the secondary portion of the domain name. The following domains are not affected by this vulnerability: .co.uk and .co.in.


Consequences:

Data Manipulation

Remedy:

For KDE 3.0.5b, 3.1.5, and 3.2.3:
Apply the appropriate patch for your system, as listed in KDE Security Advisory 20040823-1. See References.

For Mandrake Linux:
Upgrade to the latest kdelibs/kdebas package, as listed below. Refer to Mandrakesoft Security Advisory MDKSA-2004:086 for more information. See References.

Mandrake Linux 9.2: 3.1.3-79.2.92mdk or later
Mandrake Linux 10.0: 3.2-79.2.100mdk or later

For Gentoo Linux:
Upgrade to the latest version of kde-base/kdelibs (3.2.3-r2 or later), as listed in GLSA 200408-23. See References.

For Slackware Linux:
Upgrade to the latest kde package, as listed below. Refer to slackware-security Mailing List, Fri, 3 Sep 2004 22:01:35 -0700 (PDT) for more information. See References.

Slackware Linux 9.1: 3.1.4-i486-2 or later
Slackware Linux 10.0 and -current: 3.2.3-i486-2 or later

For Conectiva Linux:
Upgrade to the latest kde package, as listed below. Refer to Conectiva Linux Security Announcement CLSA-2004:864 for more information. See References.

Conectiva Linux 10.0: 3.2.3-63234U10_1cl or later
Conectiva Linux 9: 3.1.5-28535U90_5cl or later

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 10
  • Conectiva Linux 9.0
  • Gentoo Linux
  • KDE KDE 3.2.3
  • MandrakeSoft Mandrake Linux 10.0
  • MandrakeSoft Mandrake Linux 10.0 AMD64
  • MandrakeSoft Mandrake Linux 9.2
  • MandrakeSoft Mandrake Linux 9.2 AMD64
  • RedHat Enterprise Linux 2.1 ES
  • RedHat Enterprise Linux 2.1 WS
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Enterprise Linux 3 WS
  • RedHat Enterprise Linux 3 Desktop
  • RedHat Enterprise Linux 3 AS
  • RedHat Enterprise Linux 3 ES
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • Slackware Slackware Linux 10.0
  • Slackware Slackware Linux 9.1
  • Slackware Slackware Linux current
  • SuSE Linux Enterprise Server 8
  • SUSE SuSE Linux 8.1
  • SUSE SuSE Linux 8.2
  • SUSE SuSE Linux 9.0
  • SuSE SuSE Linux Desktop 1.0

Reported:

Aug 22, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page